Roon app for Remote control won't work on my laptop

Hi, pretty new to Roon. It’s up and running; I’m using my Windows Media Center PC (64 bit) as the core and I’m playing it now.

I loaded the Roon app onto my laptop to use it as a controller. The app launches, I select Use PC as remote control. It finds the media center’s internal IP and tries to load, cycling between Connect and Failed over and over. Yes I tried rebooting the laptop, uninstalling/reinstalling Roon, and checking the IP.

Nest suggestions?

Thanks, Neal

If your pc has an Ethernet port try temporarily connecting it to see if connectivity improves, have you also tried disabling any antivirus software and firewalls again just temporarily for diagnostic purposes?

Fancy new laptop doesn’t have an Ethernet port, and I don’t have a USB-C to Ethernet adaptor cable. Shut off firewall and anti-virus and still getting Connecting-Failed.

Hello @nealsal,

It would be helpful if you could provide some more information about your network configuration. What type/model of router do you have? Are you using any hubs/switches? Any network extenders? Also, please check and make sure that your devices are on the same subnet. To do this, make sure that your laptop’s first three digits of its IP address are the same as your Media Center’s.


OK I give up- not that essential…

maybe the wifi is not on the same network segment or is on a guest wifi connection?

Or more likely your firewall is active for the core and or new laptop…turn both off.