Roon app on Win10x64 (build 1903) crashing after latest windows update (28 Feb 2020)

Hi there,

I need some help with a new crash that only started right after the latest windows 10 updates were applied (Windows .NET cumulative updates). My Windows 10 is 64 bit, running build 1903 (not updated to 1909 yet).

My set up has a roon server on a dedicated machine, my audio playback PC with the Roon UI is the one crashing. The splash screen shows briefly, but with a white background with a red X . A few seconds later it will disappear and I’m back at desktop. A screenshot of what I am describing above is enclosed.

I have tried uninstalling Roon and reinstalling it on the playback PC (while keeping the settings and database) and it still does the same thing, repeatable every time. This PC has 32GB of RAM and is a i7 8700K rig with Samsung Evo 960 SSD.

To be clear, this is affecting only ONE playback PC. I have no problems accessing Roon via the control app on or my other PC (so far), and my iOS / android apps and endpoints through the rest of my home are fine, the Roon server is fine.

Please advise what I can do to resolve, or if you need logs etc.

Thank you.


Looks like the windows update has rolled back your graphics card driver. Go look for a newer one or roll back the windows update.

Thanks… I have just installed the latest Nvidia driver (27/2/20 release date) for my GTX1080 after seeing your feedback. Unfortunately, I still see exactly the same white box with red X on startup.

Hi @Ken_Ji_Ling,

Can you use the directions found here and send us over a set of logs from the affected machine using a shared Dropbox link? Thanks!

Hi @dylan ,

Thank you for your reply. I have sent you a PM with a dropbox link to my PC’s logs.

Hope to hear back from you soon, thanks !


Hi @dylan , just checking if you received the logs via PM in good order. Thanks, KJ

This stands out to me in the logs - some exception logged

Roon Version: 1.7 (build 521) stable
OS Version: Windows 10

Application Domain: Roon.exe
Assembly Codebase: file:///C:/Users/Ken Ji/AppData/Local/Roon/Application/Roon.exe
Assembly Full Name: Roon, Version=, Culture=neutral, PublicKeyToken=null

CPU0 Description: Intel64 Family 6 Model 158 Stepping 10 3696 MHz (64-bit)
CPU0 Num Cores: Physical: 6 Logical: 12

GPU0 Description: NVIDIA GeForce GTX 1080 0 MB
GPU0 Video Mode: 2560 x 1440 x 4294967296 colors
GPU0 Driver Version:

SCREEN0 Name: \.\DISPLAY1 (primary)SCREEN0 Bounds: 0,0 2560x1440

Exception Source: BrooEngine
Exception Type: System.Runtime.InteropServices.SEHException
Exception Target Site: Gdi.SwapBuffers
Exception Message: External component has thrown an exception.
Exception Data: none

–[ Stack Trace ]------------
Broo.Gdi.SwapBuffers(IntPtr deviceContext)
BrooEngine.DLL, N 0
BrooEngine.DLL, IL 315, N 388
BrooEngine.DLL, IL 466, N 1199
Sooloos.Application.Main(String[] argv)
Roon.exe, IL 1496, N 3436

Hi @Ken_Ji_Ling,

I just wanted to let you know that the logs were received and that I have a meeting scheduled with the QA team today to discuss this issue. I’ll be sure to follow up as soon as I’ve met with them.

1 Like

Thanks for the reply @dylan , cheers :beers:

1 Like

Hi @dylan , any updates from QA on what i can try to do to resolve this problem? Haven’t been able to use Roon on my main HiFi rig for a week :frowning:

Apologies for the delay here, @Ken_Ji_Ling.

I was able to chat with the team about this further today and, after they spent some time analyzing the logs that they sent, it appears that there is something related to Roon’s interaction with your device’s GPU drivers that is causing this issue.

How did you go about updating the drivers for the GTX? Can you also try to update the drivers for Intel?

Hi @dylan

My media playback computer runs the Nvidia GTX1080 exclusively, any Intel GPU onboard the CPU has been disabled from BIOS and has never run.

For Nvidia driver updates, I typically just use the driver update tab and clean install option within Nvidia GeForce Experience.

Do all the logs show the same error consistently ?

I could try using a third party tool like DDU to totally clean the Nvidia driver out and reinstalling it, but note that I did not make any GPU driver updates or changes when this problem surfaced.

Ken Ji

Hi @Ken_Ji_Ling,

Can you try downloading .NET Framework from this link and let us know if that helps?

hi @dylan,

I have managed to get Roon working again on my PC.

Steps taken -

  1. Downloaded the DDU Utility from Guru3D, reboot Windows into Safe Mode
  2. Completely cleaned out all Nvidia drivers and manually reinstalled the latest Nvidia drivers

At this point, Roon still crashed on launch, same error as before.

(3) I decided to update the graphics card manufacturer’s GPU utility that controls the fan, voltage and overclocking settings (ASUS GPU Tweak II).

One more reboot later, and Roon finally launched without issues again. This was achieved with the previous build of Roon by the way, I noticed there is an update today.

These applications often have overlay features that function by inserting themselves between applications and the GPU. Any time an application does this, there’s an opportunity for something to break.

Hi @allan , I reckon the GPU utility is almost a must on full powered PCs with high end graphics cards as we can turn off the fans to run passive mode for noise control, or crank it up for gaming.

In any case, I have Photoshop, movie editing software, general productivity apps and games on the same PC, and the app did not trip up anything except Roon. Unfortunate, but glad that updating it or reinstalling it solved the issue for me. Hope the feedback helps for anyone facing this issue in future.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.