Roon ARC 2 - Poor Connection Outside Home - Nucleus - Mark Levinson ML519 - Technicolor Router (ref#8M2XWL)

Affected Product

Roon ARC

ARC Issue Category

Can’t connect outside the home

Description of Issue

I am running Roon Nucleus. Roon works perfect inside our home. When I test Arc in the Roon APP it says READY. But ARC says poor connection. I have checked portforwarding in my router and it looks all good. Please help

Roon Core Platform


Roon Core Specifications


Connected Audio Devices

Mark Levinson ML519

Home Network Details

Router is Technicolor with ethernet connections all the way


Hi @lennartkampgaard,

Thank you for your patience. We have a few questions to help narrow down what’s going on here:

  1. Do you ever receive a message in ARC other than “Core Unreachable” pictured above? What about when you turn off WiFi on the phone while at home?

  2. Did you experience this error prior to the most recent Roon/ARC update?

  3. Do you ever experience connectivity issues on your home WiFi?

  4. Lastly, do you have any additional routers or access points in your local network setup, or is the Roon Nucleus+ connected directly to the Technicolor?

Thank you!

Hi Connor

Thank you for taking this issue seriously. I appreciate that.

First I will give you a more precise description of my setup. Please note that I have no knowledge of how the internet works.

My internet goes directly into the Technicolor Router. The Technicolor works in router mode and the connection mode is DHCP. In port forward I can see the Roon server IP and the correct port number taken from the Roon App.

I use 2 outputs from the Technicolor.

One output goes directly via Ethernet to a switch which via Ethernet leads the signal to 7 clients. Among these clients is my Nucleus. All 7 clients works perfectly.

The other output goes via Ethernet to a Nokia wifi extender (Beacon 1). My Iphone is connected to the Nokia extender. The Nokia is in Bridge-mode.

I have tried to disconnect the Nokia and use the wifi in the Technicolor to test if it is the Nokia that is the problem. It is not. I have still no (poor) connection to ARC when I turn wifi off. ARC works fine with the wifi on.

And now to your questions:

  1. ARC says poor connection and sometimes Can’t connect to your Roon Core and Core unreachable when wifi is turned off. ARC works fine with wifi turned on.
  2. No. A month ago ARC had no issues. I used it in the car with no problems. But I can’t tell if it is the recent update that is the problem. At app. the same time I changed the wifi extender from a Amplifi to the Nokia – but that change does not seem to be the problem.
  3. I have no connectivity issues on my home wifi.
  4. I have already answered that.

Please note, yesterday evening I lost all my playlists made in Roon. I have now only the playlists from Tidal left in my library. Can you fix it?

Kind regards

Lennart Kampgaard

And a bit more information:
I have tried to test different firewall security level settings in the Technicolor. Low, Medium, High and Custom. It is interesting to notice that when I change the settings, to no matter what setting, ARC can connect for a while with wifi turned off. But after a short time the problem is the same. No connection when wifi is turned off. It seems like a firewall problem? But none of my firewall settings in the Technicolor solves the problem… Hmmm

Hi Connor
Any news?

Hi Connor
Any news? It still does not work.

Hi @lennartkampgaard,

Thank you for your generous patience and please accept our apologies for the delay.

Are you physically able to bypass the switch entirely, connecting the Nucleus directly to the router via hardwire? This would be a temporary test.

If the router settings have any effect on symptoms at all here, then the issue resides somewhere within the router. I first recommend verifying that the DNS server assigned is reliable, like Cloudflare DNS, Quad9 or Google DNS.

Do you have a static IP address assigned to the Nucleus?

Hi Connor
I have bypassed the switch entirely and connected the Nucleus directly to the router via hardwire. It does not work.
I have tried with a static IP address to the Nucleus. It does not work.
But entering the router and press save to firewall settings and ARC does work with wifi turned off for half a minute or so. And then no connection.
How do I check out the DNS server? Can’t find anything in the routersettings.
Thank you.

Hi @lennartkampgaard,

Revisiting this thread with another suggestion that has come to light in the interim.

Have you tried a separate APN in the Nokia network settings? Certain providers, like Three UK in this thread, have an implementation that requires users to select a separate APN than the default.