Roon ARC and Orbi RB850/Bell Home Hub 3000

Roon Core Machine

ROCK on Intel NUC. Roon 2.0 build 1128

Networking Gear & Setup Details

Orbi RBR850, firmware V4.6.8.2_2.1.9, on Ethernet, No VPN
ISP BellMTS. Home Hub3000. Orbi hardwired to HomeHub.

Connected Audio Devices

Iphone on wifi, Cambridge 851N - on ethernet

Number of Tracks in Library

10000 tracks

Description of Issue

RoonARC not connecting. UPnP on on ORBI, now turned off on HomeHub, set static IP for ROCK, and tried manual port forwarding. No luck

Log:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“206.45.1.243”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

Thx for help

Same error here with similar setup. Only difference is my ISP is AT&T, but rest looks just like my setup with the same error message. Filed a ticket. No updates yet.

I have the same error message on my Orbi RBR850.


I have same error message with my orbi. No reply from support. Contacted them 14 days ago.

Fixed by turning orbi into access point, and assigning static ip for ROCK on the homehub. Seems to be all good now.

I got this sorted. When my ATT tech installed my service I asked for no NAT on the residential gateway. It seems that is not an option. I set my Orbi to AP mode and set up port forwarding on the residential gateway and it now works. I wasn’t aware double NAT was occurring.

Is there a downside with the AP mode with regards to network security? I have no idea.Are there any downsides compared to Router mode?

Fro me once I set up port forwarding on my isp router my Orbi worked fine in router mode without putting it into access point mode.

My residential gateway does NAT and firewall so no security issue other than the open port.