Roon Arc can't connect to Core via BGW320-505 / AT&T

Roon Core Machine

Windows 10 Laptop 32gb ram
Intel Core i7 6820HQ
All devices running latest Roon versions

Networking Gear & Setup Details

BGW320-505 modem/router
AT&T in Los Angeles
Wifi
No VPN etc

Connected Audio Devices

Relevant to this issue:
Roon Arc on Samsung Galaxy S9+

Number of Tracks in Library

~15k tracks?

Description of Issue

Roon Arc "Can’t connect to your Roon Core. Check your Roon Core and try again.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“99.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}


I’ve searched BGW320-505 here and generally and it appears this router doesn’t make this type of change easy. There’s no mention of UPnP or NAT-PMP.

Whatever I’ve found here in reference to the BGW320-505 doesn’t seem to land on a resolution. Questions/guidance in those threads I’ve seen from Roon don’t make sense to me because I can’t find anything directly related to it in the router admin settings.

Roon response there, I can’t tell what of it is relevant because I’m not using a separate router. I’ve spent about an hour reading through posts (here and elsewhere) about doing this type of thing on the BGW320-505 and I’m spent. Seeing comments like “ATT doesn’t like anyone bypassing their router. And even just making their router a passthrough really sucks…” and can’t spend more time seemingly working on a network admin degree on my day off.

Does anyone have point by point instructions on what to do in the admin settings on this specific router? Again, the Roon documentation and whatever else I’ve found here seem like it’s not even talking about the same thing.

Stubbornness prevails?

Switch to Default Server. Choose Roon Core IP from list for Default Server Internal Address.

Passthrough Mode, can’t edit it so it’s DHCPS-fixed.

Passthrough Fixed MAC Address and the rest: beats me so left it empty.

Tada:

Now onto “Poor Connection” when I try to play files. Likely due to my mobile reception being terrible since I live in a concrete fortress and can barely make phone calls. Will test once I’m on the outside.

The frustration up there^ is from the fact I’m following help docs to the letter and I just don’t see it directly lining up with how its framed by this router. Might be blatantly obvious to the better informed but I found this nearly impossible to track the docs to what I see in the router. Fiddling + dumb luck seem to have landed me at the solution.

Anyway, if you have the BGW320-505 and a similar setup and problem, hope that helps.

I have the older Pace 5268AC gateway, so these are just some observations as the interfaces are not identical to the BGW320.

I don’t believe you want IP Passthrough as this may reduce or eliminate AT&T’s ability to provide security to your passthrough’d device and expose your Roon Core to the Internet. I believe you want to use the NAT/Gaming tab and configure a port forwardng rule pointing to your Roon Core IP address using the port number shown in Settings → Roon ARC.

Good to know, thanks!

use the NAT/Gaming tab and configure a port forwardng rule pointing to your Roon Core IP address using the port number shown in Settings → Roon ARC.

The only thing I can get into on that tab that makes any sense is, and how far I can get with it. Getting that range from:

Using a different port

Roon uses port 55000 by default, but you can pick a different port if you’d like.

Feel free to use any available port in the 10,000 to 65,000 range.

No idea what I’m doing here clearly.

My recommendation is to use a port range of 55000-55002 if port 55000 or 55002 is shown in the Settings → Roon ARC tab in your Roon Core (sometimes it’s a different port number, but you can select the specific number, 55000 or 55002 is a good choice). The Base Host Port should be one of these values in your range though.

Then you need the port forwarding rule to point to the local IP address of your Roon Core, probably in the 192.168.1.xxx range based on how AT&T configures the local networks from their gateways. Does this help?

Roon shows:

image

I can save this setup now:

Back home so can’t properly check given my terrible mobile connection from my apartment. Shut off the passthrough settings for now.

Many thanks for the help. Will check it out more tomorrow.

Hi @Hazen,

In the latest screenshot i think you need to enter by Global Port Range the number 57509 and at Host Port also 57509 (that’s already correctly entered.)

You could also take a look at below YouTube video.

I hope it helps.

Kind regards,

Maarten

1 Like

@Hazen, I agree with @Maarten_Duits, your port forwarding range needs to at least match what is shown in your ARC screenshot, port 57509, or choose to Reset the ARC port, or choose 55000 or 55002 and enter that in the ARC PORT box in Roon.

Excellent, seems to be working. Kept 57509 and extended the range up to that.

Thanks all for the speedy help :metal:

Hi @Hazen,

That’s good news. Personally i would also change under Global Port Range the 55000 to 57509. In my opinion that’s better, security wise.

Enjoy the music.

Kind regards,

Maarten

1 Like

I agree with @Maarten_Duits, best to have as few ports available for forwarding for security reasons.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.