Roon ARC configuration AmpliFi HD Mesh Router

Roon Core Machine

Bluesound NODE 2i: V4 Streaming music player

Networking Gear & Setup Details

Xfinity xFi Gateway modem connected to a wired Ubiquiti AmpliFi HD Mesh Router.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon works perfectly but I cannot seem to configure the Arc.

My error copy is:

“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“73.ggg.hhh.iii”,“actual_external_ipv6”:“fd45:jjj:kkk:lll:mmm:nnn:ooo:ppp”,“router_external_ip”:“”},

“status”: “status”: MultipleNatFound


“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}


Attached are Amplifi and Roon Arc screenshots.

Thank you… very stuck.

Double NAT: both your xFi Gateway and the AmpliFi are doing NAT, that won’t work. You can set the AmpliFi to bridge mode, which will make it rely on xFi for DHCP and NAT. Then you need to persuade the xFi to let Arc through, presumably by enabling UPnP on it (I have an AmpliFi, but I replaced the xFi with a different cable modem so I don’t recall how to make this work for the xFi).

I enabled bridge mode and UPnP. Still no luck. Any more suggestions?

UPnP on AmpliFi or on xFi?

Add images

UPnP on AmpliFi and xFi are enabled

Hum… I don’t know enough about UPnP settings on those two devices, but I’d think that if the AmpliFi is in bridge mode, the only UPnP service that should be on is the xFi one.

Hi @Patrick_Cummings,

Thank you for your post and we’re sorry to hear you’ve been having trouble configuring out-of-home use with ARC.

Initial Troubleshooting

  1. First off, if possible, try connecting your Core directly to your upstream Xfinity router and checking if auto-configuration of Port Forwarding in ARC is successful. This will allow us to rule out a double-NAT situation in your mesh network
  2. If you’re unable to physically connect your Core to the upstream router, then try changing the port assignment in Roon → Settings → ARC from 55000 to another similar number. I recommend augmenting in intervals of about 200 (55200, 55400, etc.). Xfinity may have ports reserved on your network that it is using for other services, and 55000 might be among them. Similarly, other software on your network may also be blocking ports.
  3. Disable any firewalls
  4. If none of the above work, proceed to the step Manual Port Forwarding below

Manual Port Forwarding

  1. Navigate to Roon → ARC → Settings again to view the static IPv4 address and port assignment of the Core.
  2. In your AmpliFi web administration, navigate to a tab labelled “port forwarding” or similar. There should be an interface for adding manual TCP port forwarding rules, with prompts for a static IP address and port assignment.
  3. Copy/paste the static IP and port assignment from Roon → Settings → ARC into a new port forwarding rule.
  4. Repeat steps 2-3 in the web administration for your Xfinity router, creating an identical port forwarding rule.
  5. If you are still having trouble, please try changing the port assignment to a different number in Roon → Settings → ARC and in both respective port forwarding rules.
  6. If you continue to experience port forwarding failures, please delete the port forwarding rules you’ve tried and proceed to the next troubleshooting path below, IPv6

This method does not require UPnP or port forwarding.
If your Core, your router, and your ISP account all have IPv6-format addresses, you can enable or prioritize IPv6 in your network settings.

  1. Your Core has an IPv6 address
  2. Additionally, I recommend toggling on any settings in your Xfinity web administration related to Prefix Delegation. These will likely be under a tab related to IPv6.
  3. If there are IPv6 settings related to “IPv6 firewall” or “IPv6 pinholing,” then please share a screenshot of those settings.

We’ll keep an eye out for your response. Thank you!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.