ROON ARC doesnt work outside home

Roon Core Machine

Core on iMac Pro.
Remotes: iPad Pro running 16.3.1 and iPhone XS running also running 16.3.1.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

So far my experience with ARC is fine as long as I don’t leave the confines of my house.

Have yet to get it to play on Car Play (keep getting error message cannot load) and whenever I leave the house for more than a day I have to reboot my mobile devices and my core in order to have ARC update on mobiles.

All other functions on my home wireless network are OK as well as other streaming services on Car Play.


Is your external ARC access confirmed to be working in Roon > Settings > Roon ARC, or is there an error message.

Are you ensuring that your iMac Pro keeps running and isn’t going to sleep? Because then ARC won’t work.

If you leave the house, keep in mind that your iPad would need to be the version with a cell network module built in, and have a SIM card, as long as you are not logged into another wifi somewhere else

1 Like

Suedkiez thanks for response. I do have SIM card in both mobile devices. I did not have core on never sleep so have changed that. When I go to Roon Arc on mac core all I get is a continuous loop on Testing but no error message. The port is the same port as when it is working correctly

Ok, the not sleeping will be necessary in any case. The endless “testing” is currently an issue affecting some people and preventing ARC from working:

I’d wait until this is fixed completely before spending time on it

And there you go :slight_smile:

Well the new release did nothing to fix RA and AP interface when I am not on a wifi network. Have tried all the researched fixes out there…update software, confirmed my router allows remote access…and same problems still exist. Kind of giving up on that for now and stream from Tidal, etc. A new issue has come up…might be related to new release or not. I have difficulty accessing My Roon Mixes. I get the following when I try to access and rebooting the iPad that I am using seems top be only fix so far. This does not impact and of my Roon playlists, nor genre radio, etc. Here is screenshot of what Lixes looks like.

I just meant that it would fix the endless “continuous loop on Testing but no error message” as this was a temporary issue in Roon, and to wait for that to be fixed so that you can see if there’s an error message and before spending time on the other issues. Those are probably a different thing entirely.

Now that the endless testing loop is hopefully gone, do you now see an error message in Roon > Settings > Roon ARC?

(And the screenshot you tried to post did not work out, there is nothing to see)

Thanks for your help on this. My Setting>Roon>Roon ARC still giving me same error message. Find it strange that everything but My Roon Mixes works fine on wi fi network. And now it’s not even being fixed by a reboot. When I try to play a Daily Mix the playlist shows up but the artist photo anddisplay below it is blank and won’t respond to either Play or Shuffle. About to bail on having ARC as a meaningful alternative for now. Thanks again

Which one? You haven’t posted it yet because when this thread started it was spinning “testing” and didn’t show one. That was a common issue at the time and should have been fixed by the update, and did for most people.

Is it still spinning “testing” for you or is there now a message?

Is this only in ARC or in the regular Roon as well? I am getting a bit confused here :slight_smile:

The Daily Mix shows up on Roon and ARC.Mixes play fine from core but have been unable to stream whole house from my setup (Seagate HD and Tidal; Mac Book Pro running latest update, Oppo Pre Amp, Arcam integrated amp. ARC works well with Air Play as long as I am on wifi

I am still confused. We need to separate the issues out.

Using regular Roon or ARC or both?

But not at all outside of the house on the cell network? And did that ever work or not? Again, is there now a message shown in Roon > Settings > Roon ARC or is it still spinning “testing” for you?

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I get an error message saying Roon Arc can’t connect to Core and the above diagnostics.

What network equipment do you have and which ISP.


Eero mesh network and ATT internet

Hi @Ricky_McGrath,

Usually, you’ll need to set a manual port forwarding in the Eero mesh network main router and the AT&T modem. More precisely, in the Eero Network Settings page of the router’s web administration, head to → Reservations & port forwarding,

Add a reservation for the RoonServer static IP address and port number from the ARC settings page in Roon. Select the TCP protocol.
Toggle the Port Forward on, and UPnP off.

In the AT&T modem, try to enable Bridge mode or set an identical port forwarding rule. Also disable UPnP in this web administration.

Please let us know if the above steps help.

1 Like

I have followed the provided instructions. I could not find out how to change my modem to bridge but I did set port forwarding to the same port for Roon and chose the TCP protocol. I could not find a place to disable UPnP but that may be a function that ATT doesn’t allow/support the protocol on their modem? In any case will try to give it a go from a remote location this evening or tomorrow and will report back. Thanks for your help.

Connor, tested this morning and still unable to use ARC over cell. When I attempted to play this morning the home page was populated (without in some cases metadata like pictures) and in some cases song lists would appear. But when I tried to play got the eoor message “something went wrong…data could not be loaded” on Car Play screen. When I tried to play on iPhone untehered to Car Play I got eroe messages “Core unreachable” and, in red banner, “Poor connection.” I had 4-5 bars on my cell reception and could access Tidal and Apple Music without an issue. Any thoughts moving forward? Thanks

AT&T don’t allow bridge mode

@connor am I correct in saying the OP will need dual port forwarding rules to achieve Roon Arc outside of the network?

Menzies thanks for your feedback. Followed the steps attached to your reply. The router says remote access is now enabled but obviously there is still issue.