Roon ARC failing to configure port forwarding

Roon Core Machine

Roon Rock dedicated machine

Networking Gear & Setup Details

Networking is Google Nest behind BT Hub 5

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon Arc on PC. Windows 10 and IOS device both fail to configure port forwarding. Roon running on PC gives this diagnostic:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“192.168.x.xx”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

@hecd2, it looks like you may have a double-NAT setup. Take a look at this post; it may help. Otherwise, wait for support.

1 Like

Hey @hecd2,

@Martin_Webster is steering you in the right direction here!

As an additional next step, please connect your core directly to your main modem and see if you run into the same error message.

If so, there is a chance your ISP is running CG-Nat, in which you’ll need to reach out to them to request a static IP address.

You can read more about that here:

I’ll be monitoring this thread for your reply :+1:

1 Like

A post was split to a new topic: ARC Port Forwarding Issue

Core connected to BT Home Hub 5: I cannot get any error message because Roon on PC cannot then see the core. However, Roon ARC on mobile device still cannot make a connection to the core (“nor accessible outside of your network”). My ISP is BT, one of the biggest in the UK and does not offer static IP addresses. I don’t understand why your implementation will not work on my set-up when I have access to my Synology RAID from anywhere in the world via DS file app on mobile - naively, it seems to me to be the same sort of requirement.

You don’t need a static IP; a dynamically assigned IP address works.

Most likely you have multiple NAT since you are using Google Nest with the BT Home Hub. This is clear in the status message you posted.

Please look at this guide, especially the section, Multiple NAT.

NAT lets all the devices on your network share a single “external” address, via your router.

However if there’s more than one device between your Roon core and the public internet which are both configured to do this “translation” process, Roon won’t be able to configure your network to allow access to your Roon Core.

Thanks for your help. Seems that I’m stuck. My ISP provided modem/router does not allow bridge mode and the mesh system does not work unless it is a NAT. So no Roon ARC for me it seems. Pity.

A post was split to a new topic: ARC Multiple NAT Setup Problem

This shouldn’t be a problem. You can do one of two things:

  1. Setup Google Nest to use PPoE, and remove the Home Hub (please provide model number)

  2. Setup port forwarding in both devices

1 Like

OK, so it’s not Google Nest mesh , it’s Google WiFi mesh. My bad. So let me clarify a few things:

  1. If I set up PPPoE on the Google do I need to buy a Modem, as the BT Home Hub 5 cannot be put into bridge mode?
  2. If I buy a modem, do I need PPPoE? If I put the modem in bridge mode doesn’t that solve the double NAT issue?
  3. How does setting up port forwarding on both devices solve the double NAT, and how do I do it?

No need to buy a modem (I’ve not used BT for some time, and thought they offered bridge mode), but instead set up port forwarding to Google mesh in the Home Hub. Then repeat this with Google mesh or use UPnP.

Make sure that you use the same port as shown in Roon ARC settings for both.

1 Like

Martin, great, thanks. That worked a treat.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.