Roon ARC failure with Tp-link AX1800 wifi 6 router

Roon Core Machine

Dedicated server is sonicTransporter i5 (1st gen I assume) by Little Green Computer LLC. Using static IP address.

Networking Gear & Setup Details

Router is Tp-link AX1800 wifi 6 router with Ethernet distribution via Tp-link powerline system.

Roon server (sonicTransporter i5) is connected via powerline Ethernet to router.

Connected Audio Devices

MiniDSP Studio streamer connected via powerline Ethernet.
SPDIF cable output to Chord 2Qute DAC.

Number of Tracks in Library

10,500 tracks total.
3,600 tracks on NAS (Synology DS218) server which has powerline Ethernet connection.
Balance of tracks are TIDAL.

Description of Issue

Folllowing instructions for Roon 2.0 setup I get failure message:

However the Tp-link router does show Roon server as a UPnP client:

I tried a manual setting for the ROON server, but the router requires a “service” to be specified…which service?

Have ben trying different services but no success.

Have spent enough time on this ARC service. Seems to be one of those “it would be nice, but not essential” types of things!

I have the same issue so I’ll be monitoring answers to your post. Fingers crossed

Hi @David_Williamson

I have a TP-Link Deco X68 running at my In-Laws premises, initially it didnt work with UPnP so I manually set up Port Forwarding, it looks quite different from your interface but has been working without any major issues, here are my settings:

According to the diagnostics window on the Roon ARC tab it looks like you have run into a Multiple NAT issue.
Roon support will need the model of your ISP’s modem to start with.
Do you have your modem set up in Bridge mode.
Does your ISP use CG-Nat? (Apologies if you don’t know what this is).
Is your modem connected directly to your TP-Link Router?

It may take some time but if you persevere you will hopefully be able to get to the bottom of the issue.

Hey @David_Williamson,

Ben here with the support team, my apologies on the delay in follow up! I wanted to check in and see if you were still running into connection issues with arc.

@oneofmany is steering you in the right direction with next steps and questions. I’ll be monitoring this thread for your reply :pray: