ROON ARC- fixed my Double Nat problem, still won't contact

Roon Core Machine

Mac mini M1, 8GB RAM, 500 GB SSD

Networking Gear & Setup Details

Modem: ATT provided BGW320, IP passthrough enabled
ORBI Mesh WIFI 6 router, model RBR750

Connected Audio Devices

IfI stream, ARC on iPhone

Number of Tracks in Library

All Qobuz streaming

Description of Issue

So excited for ARC.
On update, I found Double NAT reported. Googled my setup, followed. instructions to set IP passthrough on my model. Also disabled the wifi. Went to the Orbi menu and turned UpNP on and off to reset. Reset modem (ATT BWG) and router (ORBI). On checking, the DoubleNat flag went away, but still did not pass on the check in the Roon 2.0 app.
All my internet function is working fine, just the Roon won’t work.

Here’s the errors, any help appreciated.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

Searching on the forum I found this post by Roon Support. Perhaps it helps.

Thanks for response. I already removed that Double NAT issue thankfully!
I already put the BWG modem into “IP passthrough”, which is the 'bridge mode" for that modem.
It’s something else. Hopefully Roon support can add with some input.

Have you tried manual port forwarding? What.s failing is UPnP (which I’m not a fan of anyway) so I would just try setting up a manual forward on the Orbi.


I also recommend a port forwarding solution over enabling UPnP. I have the Pace gateway instead of the BGW320 and an ASUS router and port forwarding on both devices works fine over AT&T’s network.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.