Roon Arc IP showing localhost (

Roon Core Machine

Have tried 2 machines QNAP TVS-h1688x and windows 11, Threadripper, 128gb ram

Networking Gear & Setup Details

AT&T fiber bridged with Watchguard M300

Connected Audio Devices

Number of Tracks in Library


Description of Issue

I am trying to setup Roon Arc and keep running into issues. Port forwarding has been setup but Roon Arc keeps showing for the IP and am not sure how to get it to bind to a different IP.

Any help would be appreciated. Running the test in arc yields the below output:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

@Todd_Roberts, where are you seeing the IP address for Roon ARC? This address typically is assigned internally when a device cannot obtain a routable IP address from the DHCP server in your router or the ISP network.

Generally, the diagnostics you’ve provided suggest that UPnP is not properly configured on your router. I have AT&T Fiber and their gateways do not support UPnP activation.

Please first try the following steps:

  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering. I believe the Watchguard may be an issue here. Is there a port forwarding rule configuration capability on it?

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
1 Like

Thanks for the quick reply you were correct it was a watchguard issue and I got it corrected. Thanks for the help


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.