Roon ARC is not working!

Hi,
I’ve been trying for over a week now try to connect ARC with no joy. I have a BT Home Hub in the UK.
Please is there anyone who can give me a simple answer please?
I like Roon because of it’s ease but this has me beat!
Windows 10 PC. Roon Core

Thanks in advance. Jono

Looking through the forum, there are a few reports of success with a BT Home Hub (search for “BT Home Hub Port Forwarding” and look at the threads marked as solved).

It would help in diagnosis to have more information on your particular setup, so please fill in the information in the form(s) below so that Support can help.

Thanks!

===========================================================

Who is your internet service provider? (Presumably this is BT?)

Please list the make and model of your modem and router? (which model of the BT Home Hub?)

Do you have any additional network hardware, like additional routers, mesh networks or managed switches?

Does your network have any VPNs, proxy servers, or enterprise-grade security?

Hi Geoff,
I’ve read nearly evert one of the fixes and none of them work.
I have a BT smart hub 2
I have a network switch too.
No VPN or anything else.
Thanks

This the message in Roon…
{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“81.141.83.34”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.254”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}

Message sent

I have a BT Smarthub 2 and got a very similar message to yours when I first tried to set up ARC. For whatever reason the BT hub does not seem to do the autoconfig thing. So the next step is to manually set up Port Forwarding within the BT hub web access pages (should be on 192.168.1.254 via a browser). Once I did this it worked just fine.

So, have you already tried to do port forwarding in the hub?

Hi Solemar, yes I have tried this and still no joy.

You’ve probably already read suggestions about the Smart Hub. I have the first version of Smart Hub but despite having UPnP switched on, I had to set it up manually, entering the port number 55000 under the Roon ARC tab, and the following in the port forwarding section in my Smart Hub:-

Michael

PS I wonder if there’s something in Windows stopping it working for you? I use ROCK on a NUC so don’t have a Windows firewall in the way.

Resolved: Reset router port forwarding config, also fully disabled ipv6 on the router.

1 Like

Thanks a million Ratbert, I’ve been listing via ARC in the car all day and it’s brilliant.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.