Roon ARC Losing IP and Port Fowarding

ARC has become a serious PITA and I’m going back to Qobuz. On three occassions now I’ve had to change the port number as Roon has flagged up an error saying the port is already being used. Yes it is being used by itself (ARC) of course. Even after closing the ports I opened it still says the port is being used. Gives me an empty box with no port or IP information. I’ve had to change the port three times in 10 days. Not really acceptable to not know when you leave the house whether the app is going to work or not. I had high hopes for ARC and loved its inclusion in 2.0. It’s interface was a joy to use but sadly its just not stable or reliable.

Cheers Ian

Are you using UPnP or did you open the port manually?
Do you have any other devices on the network that might be grabbing the port?

If you want help with this, it would be best to move the post to the #support area. And in this case, please fill out the template for new support posts with the info about your setup:

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

1 Like

Hi Suedkiez, thanks for the response. I have UPNP enabled on the router as specified. At first I used and opened port 55000 and then 2 random ports within the specified range. I don’t have any other ports open or networked devices that should be using the ports chosen.

Cheers Ian

That’s very weird. I took the liberty of moving your thread to the #support:port-forwarding-help category so that Roon support will see it. I hope that’s OK. Unfortunately, I have no idea what is going on, hopefully someone else will chime in before Roon support picks it up (which can take a bit of time). Filling out the answers to the questions would still be helpful.

1 Like

Hi @ian_rollo
I don’t know if this will work, just an idea:
Is port forwarding activated in addition to UPnP on your router?
If so, you could try disabling port forwarding and then rebooting router, your entire network, roon core, and your phone with ARC installed.
Upnp should remain enabled.


Hey @ian_rollo,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, did @Axel_Lesch 's tip help at all? They are correct in that either UPnP or a manual port forwarding rule should be active, but not both.

If you’re still running into issues here, can you please provide a bit more information around your full network setup:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I’ll be on standby for your reply :+1:

1 Like

Thanks for all the comments guys. I did have upnp and port forwarding active. After a full reset, disabling upnp, and then issuing a new rule with only port forwarding active it seems to have settled down alot and not had any drop outs for a few days.

Many thanks


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.