Roon ARC no connection with Huawei Modem/router and Airport Time Capsule

Roon Core Machine

Windows 10 - AMD Ryzen 7, 32GB RAM

Networking Gear & Setup Details

Who is your internet service provider?

I`m in Peru and my local optical internet provider is WIN (

Please list the make and model of your modem and router?

Modem/router is Huawei Echolife EG8145V5 which is connected by ethernet cable to my Apple Aiport Time Capsule that it is conneceted to my Roon Core on a Windows 10 PC

Do you have any additional network hardware, like additional routers or managed switches?

No, just the ones described previously

Does your network have any VPNs, proxy servers, or enterprise-grade security?


How is your Roon Core connected to the internet?

Ethernet cable

Connected Audio Devices

PC to NAD amplifier

Number of Tracks in Library


Description of Issue

I can`t access and connect to ROON ARC


  • I alreday enabled UPnP on the Huawei Router
  • Already setup the Roon Connection on the Airpot with the ports 55000 and Ip address on the Nucleus description

Nothing Works…


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“status”:“NotFound”}


But your Core seems to use 55002

Yes, i did that change also and try out, first i tried with 55000

The Airport Time Capsule is a router, so you most likely have double NAT. You’ll need to enable UPnP in the Airport or port forwarding, and also port forwarding from the Huawei to the Airport.

Thanks, yes I do enable UPnP on the Airport and port forwarding the Huawei to the Airport, still not working.

I’m sending you some screenshots from the Roon Arc troubleshooting page, Huawei and Airport
setups as they are right now.




The Huawai should forward to the Airport IP address not the Roon Core, and this address is in the same subnet, i.e.,

Ok but it is not the that it is in both last screenshots “Internal Host”?

Your core is on the subnet, which is provided by the Airport. The Huawai cannot see these addresses; its DHCP server issues addresses on the subnet.

The Airport will have a address. What is this? That is where you forward. > Huawei > 192.168.18.???:55000 > Airport > (Roon core)

1 Like

Sorry if I’m not understanding, but do you mean I should change on the Huawei Internal Host: To which one?
External Source IP address, I will leave it in blank, right? > Huawei > 192.168.18.???:55000 > Airport > (Roon core)

I assume that in the above sentence what it is bold is OK so the problem is on the Huawei part? So how should it be filled the next image?

What IP address do you use to connect to the Airport? Whatever this is, create a rule in the Huawei that forwards to 55002.

In the Airport, create a rule that forwards 55002 to your Roon core, i.e.,

1 Like

But i did both steps before, if you’ve seen my screenshots i have create a rule in the airport to the Roon core:

Then on the Huawei i enabled the port forwarding and adressed to the airport here:

I still don’t know what i am missing, but i can`t use Roon ARC which was the main reason of my subscription

You have the same private IP address in both screenshots… This isn’t correct. As as I said earlier, the Huawei needs to forward to the Time Capsule, not the core.


Hi @Juan_Eduardo_Hidalgo,

It looks like you’ve got some good advice on this issue. Were you able to make any headway?


I have spent some days trying several configurations following your advice but no one works, this is the last configuration it is setup

Add images

Don’t know what else to do…

Hi @Juan_Eduardo_Hidalgo,

For your existing port forwarding rule, the external host does not need to be populated. That might actually help the situation. That said, forwarding rules will also need to be set up for your Apple airport. The status screen in Airport might actually say there’s a problem with multiple NAT and if that’s the case, it might be best to get the Huawei into bridge mode (easiest answer) or ensure both devices have a forwarding rule.


i was also looking for the same, thanks

1 Like

this forum is very helpful.. .

The Huawai should forward to the Airport IP address not the Roon Core, and this address is in the same subnet. .

1 Like

This is what I still have right now, not working! But i`m still confused what to do, whatever it is forwarding or doing the bridge mode…