Roon ARC No Longer Working after Core update to Build 1223

Roon Core Machine

NUC 7i7 running ROCK

Networking Gear & Setup Details

ASUS ZenWiFi AX (mesh wireless)

Connected Audio Devices

Nothing connected directly. Miscellaneous wireless endpoints within home (iPad, Denon AVR receiver, Wiim Mini, etc.)

Number of Tracks in Library

14,992 (local SSD storage in NUC plus Qobuz and Tidal streaming)

Description of Issue

Breaking my issue out from comments in a similar topic started by @Peter_Zwiefelhofer.

Roon ARC stopped working completely immediately after the update to Build 1223. Standard Roon on home network continues to work fine, but neither the Roon Remote software (tried on multiple devices) nor the Roon ARC app (iOS version) have been able to contact the Roon Core for ARC purposes. In the Roon Remote software, in the “Settings” – “Roon ARC” tab, it just continuously spins on “Testing” without resolution or error message.

I have verified that Roon Core is running the latest software: Roon Server 2.0 (build 1223); ROCK Operating System Version 1.0 (build 256)).

I have tried rebooting the Core (NUC 7i7 running ROCK) – multiple times.

I have tried turning off and on the UPnP settings in my Router’s Admin interface.

I have tried to add manual port forwarding according to the article here on the Roon pages.

ARC was functional on my system before the update (though with a recurring album art display problem with CarPlay – a separate issue). I did not make any changes to the firewall settings or Router configuration other than testing proposed solutions as described above.

Nothing works. Given the apparently large number of users reporting the same issue in comments, this appears to be a bug in the latest update, not a localized issue for my system, which unfortunately has killed Roon ARC – for now. But I certainly would love to hear from the Support team on this or other suggestions I have not considered yet. Thanks!

1 Like

I rebooted my NUC-ROCK core tonight, then something new happened for the first time in 3 days. After this last reboot, the “Testing” circle only went for a brief time before I finally received an error message in the Roon Remote software:

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I don’t know how to interpret this, but perhaps someone can give me some guidance?

I’m also now unable to connect after 1223 update to ROCK. I can connect to the web page fine, but the Roon app on the same windows PC, nor roon remote or roon arc on my iphone (all on the same local network) will not connect.

You’ve heard nothing from anyone?

Also seeing the same symptoms recently, and also tried the same fixes (restarts, explicit port forwards, UPNP toggling, router reboots, etc) - no good.

The only thing that has happened recently is my external IP was rotated by my ISP - normally a restart of modem, router or Roon (or all 3) would fix that - but not this time.

One thing I notice is that immediately after every restart of the Roon Server, ARC can see that it was available for a brief blip - then it goes unavailable again shortly and stays that way until the next restart.

Regular Roon continues to work fine.

Yes there were quite many other posts where ARC setup is showing “testing” forever. Roon is investigating, some of it was caused server-side and it was partially resolved but apparently not yet competely:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.