Roon ARC not able to access my Roon core

Roon Core Machine

Windows 11 Desktop PC/ Windows 10 Laptop.
Desktop - Ryzen 7 5800x 32 GB DDR4 Ram

Networking Gear & Setup Details

Router - D-Link Dir 825 AC 1200 Gigabit router
NO VPN, No Anti- Virus

Description of Issue


Roon ARC is unable to connect to my Roon Core.

I have tried enabling UPnP and also tried forwarding ports by following the instruction on Roon support website, I will be attaching screenshots for the same.

There is no VPN and I have tried this on 2 different machines my desktop as well as my laptop. My ISP will be of no help if I contact them. Kindly help me regarding this.

What I have tried? I have tried forwarding different ports
Tried enabling UPnP
Tried restarting my router/modem and my desktop and laptop hardware as well.
Tried updating my router’s firmware.


Roon Port forwarding

Hi @Rahul_Ghai,

The diagnostics data states a multiple NAT problem and as you can see the last line states server_ip where the Roon Core IP is Probably the IP address of your D-Link is the found
This means that there is a NAT/router in the chain before your router. Are you shure you don’t have a router of your provider? If not, then perhaps your provider has some NAT at their side.

I agree with @Joost_Hoogland, there seems to be another router involved in your network or being applied by your ISP. If you look at the specific IP addresses in your Roon ARC error message, you see a reference to the private LAN IP address of but also another IP address of after the address reference. The 10.247 address also is a private address.

Hi @Joost_Hoogland

Thanks for your response so is there any solution to this problem anything I can do from my side to fix this issue.



Question 1 is: do you have a additional router provided by your internet provider in the chain?

No I don’t have any additional router provided by my ISP just one D Link router dir 825.

Eh, isn’t there a port conflict? ARC is listening to 55002 and you have forwarded 55000.

Hi @Jules_Herfst
I tried forwarding both of them but it still did not work.

Then your internet provider performs NAT on their side and you will have to contact them to ask how you can use port forwarding.

Thanks for your response. I will try to reach them :frowning:

Hi @Joost_Hoogland

I tried contacting them but as for most of the IPs in my area. They don’t have a clue about it.
Anyways i tried disabling UPnP and again tried forwarding my ports. I am attaching the screenshot of the error i am getting now. Sorry I am a bit of a newbie myself to all this.


This list of questions for clueless ISP people might be helpful:

Though it will be painful. I had 10 phone calls and listened to incredibly incorrect things. You need to clear the first support level.

Maybe your ISP offers business contracts which might include a public IPv4 address and might not actually cost more. Maybe worth checking on their website

Thanks for your response @Suedkiez
I will try giving it a shot one more time although I am pretty sure they won’t be of any help sadly.

Don’t talk about running Roon, it will confuse them :slight_smile: They may have heard about people using a PlayStation for online games, or the need to run a web server on your location.

Well tried contacting them, they said “Sorry Sir I don’t understand” :rofl: well such a bummer for me Roon ARC was really a useful feature for me as i mostly stay out alot and I need my music on the go.
Thanks everyone for your help.
Happy Listening.

I was told “IP addresses only work in local networks” and “this cannot work because your phone does not have a fixed IP”. :cry: Maybe it’s better if they say “I don’t understand” right away :slight_smile:

I feel for you. Is it really not possible to ask for a technician?


Yea sadly there is no solution and I love roon just don’t wanna leave it but I guess no luck in my case.

I am going to tag @support to see if they can look into this also.

1 Like

Thanks alot @Robert_F

1 Like

Is there any update regarding this?