Roon Arc not connecting outside of home network

Roon Core Machine

Mac Mini M1

Networking Gear & Setup Details

Starhub Singapore
ASUS AC1900 Duel Band. 802.11ac
ExpressVPN installed on router

Connected Audio Devices

Number of Tracks in Library

10883

Description of Issue

Roon ARC will work at home but not when off the network. I seem to be unable to access the router directly - hence going through the ExpressVNP dashboard.

I have tried to set up Roon ARC and have tried to create a Forward Port in ExpressVPN dashboard:

I have added the Mac mini (Roon Core device) as a separate device with no VPN (see image below)

Please help - as losing the will with this.

Thanks
Jon

@jon_filer, welcome to the community, sorry to hear about your issues in getting ARC configured. A fellow user here, but let’s see what the community and Roon staff can do to help.

The diagnostics you’ve provided suggest that your Core is having difficulty reaching our servers. There are several independent factors that can cause this error, so we recommend double-checking the following to initiate troubleshooting:

  • Is your router firmware up to date?
  • Do you have any VPNs, proxy servers, or enterprise-grade security on this network? If you deactivate your ExpressVPN service, does ARC work outside your home network?
  • Are you experiencing any issues with Roon Remotes, or other apps on your local network?

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I recommend disabling your VPN first, enabling UPnP or a port forwarding rule on the ASUS rotuer, and determine if that enables ARC to work outside your home.

Hi Robert,

I think I have done this - I have set up the Mac mini (core) without the VPN running and created within ExpressVPN dashboard and forwarding rule.

Seem unable to access the router directly now

Thanks Robert for the quick response.

Router is up to-date (please see image)

I am using ExpressVPN that is installed on the router and am going through the ExpressVPN dashboard - as seem able to access the router directly now.

Network: Starhub Singapore
ASUS AC1900 Duel Band. 802.11ac
ExpressVPN installed on router

I am not aware of any additional routers or managed switches. But the internet is provided by the landlord on in the building I live.

I have no idea about Bridge mode. I have set up a forward port as per image above

Sorry, if not tech savvy with networking issues. This is a new area for me!

Really appreciate the help

Jon

@jon_filer, I am in the States and it is getting late here, so may not be able to continue this tonight. Other community members may join in during the weekend.

For now, have you set up a port forwarding rule on the ASUS router directly in its WAN → Virtual Server/Port Forwarding tab? Alternately, activate UPnP on the ASUS WAN → Internet Connection tab. In either case, to test this, can you completely deactivate the ExpressVPN service to remove that variable?

Hi @jon_filer,

It seems that your Asus router has the ExpressVPN firmware installed. Is this correct?
I’ve looked up some info on their site and it seems that all your traffic is routed through the VPN. Perhaps that is the problem, so you want to route the Roon traffic pass the VPN. You could try to make what they call an applications group that bypasses the VPN and put Roon in it. You have to look on their website or in their manual to find out how to do that.
Then with the port forwarding rule enabled see what the diagnostic message in Roon displays (hopefully Success!)

Hi @Joost_Hoogland
Thanks for the response.
I have added the Mac mini (which is the Core) to a no VPN group.
Screenshot 2022-10-29 at 6.21.22 PM
And have created a Port Forwarding rule (please see image below)

However, the issue still remains:
Screenshot 2022-10-29 at 6.24.35 PM

I have tried to reinstall the ASUS firmware, to no avail. And have tried various configurations regarding ports.
Surely it should be that difficult.

Im thinking. of buying a new router, to see if that can solve the issue, then try to get the VPN up and running after. All a bit of a faff.,

Hi @jon_filer,

Thank you for your patience as we’ve worked through the queue to reach your ARC port forwarding case. We’d be happy to support you directly or point you in the right direction if we determine the issue is with your router or service provider.

First off, the 998 status code present in the diagnostics actually indicates your Core can’t reach Roon’s servers - not just ARC on your phone or device - during the port test.

I suspect that your landlord has a modem or additional router somewhere in the building with some security settings in play or router functionality engaged. ARC requires a port forwarding rule in both routers if there are two routers connected to the same chain. After doing a little digging, Starhub Singapore seems to provide their own modem/router combination in most cases. I’d reach out to confirm the local network infrastructure before trying out a new router.

I also recommend you disable IPv6 in the router if you see an option for that under Advanced Settings or Network Settings in the web administration.

We’ll keep an eye out for your response.

Hi
Thanks for the response. I don’t think the landlord will allow me to access his router for obvious security reasons. We pay part of the monthly bill towards it, along with the other 5 flats here.

I did go out and buy a new Router and will install tomorrow so, will look and disable IPv6.

I have tried to teether through my phone - with no VPN on, and still have the following message:
{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“122.fff.ggg.hhh”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Not sure why this would still be an issue, as the 4G is strong and doesn’t have any VPN/Firewall.

Is there something I am missing here?

Looking forward to any help with this
Thanks
Jon