Roon ARC "not responding" on Android

Roon Core Machine

OS: Windows 10 x64
CPU: AMD Ryzen 9 5900X
Memory: 32GB DDR4 1056.5 MHz Dual-Channel 15-15-15-36 SDRAM

Networking Gear & Setup Details

Not really applicable to my problem, I am simply playing back downloaded tracks on Roon ARC on mobile.

Connected Audio Devices

RME ADI-2 DAC (connected with USB-B)
Running Roon ARC on a Galaxy S22 Ultra

Number of Tracks in Library

233.103 tracks

Description of Issue

The last few days, I have regularly had an error message “This app is not responding” appear when using Roon ARC on my Android phone (Samsung S22 Ultra).
It’s a standard Android error message, if I simply choose “wait” instead of “close”, Roon still seems to work perfectly fine.

The problem is that this message will continue to pop up every 10 seconds or so after clicking it away.
When I restart ARC the issue is usually resolved, so it’s not too bad, but still inconvenient at times (especially when I use it in the car).

There is also an option given “report” which I assume sends an error log to the makers of the app?
I’ve done this several times as well, but just as with “wait”, the message just keeps popping up until I restart.

Could there be some memory leak or anything else triggering this error message on Android?
Not sure if this issue has been raised by any other users, but since I’ve had it consistently happen over the past few days, I thought I’d report.

Kind regards!

1 Like

Have you tried clearing the apps cache. If that doesn’t help clear data.
Hold and press the Arc app icon, should get this

Press the ‘i’ in the circle

Then go down to storage

Then clear cache first

And then data of it doesn’t help.

Other than this, not too sure. I have a Samsung M52 and no issues.

Thanks, will give this a go and report back if it still happens or not!

Well, I tried clearing both cache and data. Restarted both app and Roon core, in the settings remote access is enabled.
I am on full wifi signal and can’t connect to the core.

I have honestly had nothing but troubles getting connection to work at all.
Sometimes downloading albums will work, other times I need to restart both the core and the ARC app in the hopes that it will work.

Honestly don’t know what’s wrong at this point. Both the machine and phone these things are running on are up to spec, up to date and everything.
I have no network issues with anything else either… :confused:

Hi @Jort_Cenens,

We’ve released a number of stability improvements in the latest ARC versions; however, diagnostics show a wide range of warning traces related to memory pressure and cellular connectivity failure on your Android.

Are you experiencing ongoing issues in ARC? The team would be happy to troubleshoot further. Please provide a basic overview of your network hardware and relevant endpoints and we’ll be standing by for your response.