Roon ARC not starting.Motorola /Android 13

Hi, my ARC app will not start on my Mororola G84 with Android 13. Dedicated Roon Server running Windows with port 50002 open. Test ok.
Thing is, the ARC app was working fine for apprx 2 days. I have tried to reinstall, but with no result. Just a big fat ARC-logo shows on my screen. Help is appreciated.

Hi @Nils-Elling_Stubberu

Just a fellow user coming from a Motorola G73 and found Arc a mix of success and failure.

Try going into the apps info settings and clear the cache. Then force close the app. Then open the app.

Seemed to work for me on the numerous occasions I had trouble.

Side note: now on an iPhone 13 and having Arc issues here to.

Good luck

Thx for reply.
Problem solved. Installed arc manually from this link provided by RoonLabs: 3
All working perfect, for now.
Anyways, thank you.

Be aware that APK installs will not receive further updates through the Play Store.

I will. Thx.
They send me the v. 1.0 (226). Which is as far as I can see the latest version? Correct?

Yes, you can always find the latest version numbers here:

But when an update is released, you will need to install the new APK if you stick with that.

We’ll do. Thx for all the good words that always exist among audiofile people. Confirms I’m on latest version and I think I will stay with the APK for now. ARC is still a fairly new build (1.0) and I don’t mind following it manually as it seems to be a safe way considering my telephones brand…
This weekend I will work on my server to install ROCK.
I love the Roon software and the people around it (Samsung excluded).
Thx again.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.