Roon Arc not working, ISP done all they can

Well, they don’t seem to know what I ask for, and I really don’t know how to ask in a way that they would understand. All of this is spanking new to me. A few days ago I was vaguely aware that there are somethings called ports in a network, and now I desperately try to get a grip.

OK, seems like the thing to do. I’ll start over

Is this the only router you have in your home network? If so, then the muliple NAT situation is down to something that your ISP is doing upstream.

Second question, is the Zyxel connected to your telephone landline, or is it connected to a 3G mobile network used by Bahnhof?

I also suspect that it’s a Case B senario. The only recommendation I can find in the document is to get a Static Public IP-adress. I have got one, so I think that I need something else to try

Zyxel is the only router.
It’s a fiber optic connection. Bahnhof says that they do not perform NAT from the Optic to Ethernet modem.
Earlier I got rid of the multiple NAT error when I closed VPN, but it’s off now.
I have had four support calls to Bahnhof with four different technicians. I will try again and hopefully get one that understands my questions, that I really doesn’t understad fully myself

Are you sure you have a true static public IP4 address, and not one that is provided via CGNAT? Apparently, many Swedish ISPs use CGNAT which is a problem…

That tells me that your support person at Bahnhof does not have a full understanding of the technology they are using… :roll_eyes:

Well, that’s a concrete question, that I can ask when I call. I certainly hope that that it’s the right one since I now pay extra!

I suppose so. But they do go and ask some colleagues sometimes if they are stumped, so they do try, I think

I had the same problem. Behind a CGNAT. I found a solution and put it in this thread, maybe it can work for you.

OK, that looks interesting. But too much to ingest on my lunch break. I have to come back to that.
I have chatted with Bahnhof and they deny that my IP-adress is a CGNAT-adress.

Well Bahnhof tells me that it’s not a CGNAT provided adress but a public IP4

Well, very strange that you’re seeing a multiple NAT being reported in the error message.

Can you remove any port forwarding rules from the Zyxel that you may have set up, enable UPnP on it, and see what Roon errors you get then?

100.x.x.x is most definitely a CGNAT IP address

CGNAT uses ( >>

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

A few minutes later, back to this:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xx.xx.xx”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

OK, I’ve edited out your public IP address from that error message - like your personal email address, that’s not something you should be revealing in a public forum.

That form of error message is shown in the ARC Port Forwarding FAQ, and tells us that we need to do manual port forwarding.

At least the multiple NAT message seems to have gone away - perhaps there was something misconfigured in the modem?

But first, try the steps outlined in the FAQ under “Other Tests” and see if that gives any positive results.

Well I have tried all of that except firmware update. I couldn’t do one when I tried yesterday, but I’ll have another try.
But now it’s back to multiple NAT again. I’ll see what Bahnhof has to say.

I will ask ISP one more time.

Use GRC shields up to see if the port is open.

No point in trying to fix roon if the traffic isn’t even getting to the router or through the port forward.