Roon ARC on Galaxy S9 phone with Dragonfly Red DAC

My Roon ARC seems to work fine with the headphone output on my Galaxy S9. I thought I would try my Dragonfly Red DAC to see if audio quality improves. I couldn’t see any change in the audio quality.
When I enable USB Driver (Beta) in the settings, I get an “audio device error”. I couldn’t get it to work with USB debugging, etc.
So I switched off the USB driver in Roon ARC settings.
The audio quality is the same with headphone output and with the Dragonfly. I get the blue logo on the Dragonfly, so it is always downsampled to 48kHz, same as the std headphone output on the S9.
I can’t find anywhere in my phone or in Roon ARC to change a setting to get the better sample rates.
Is it possible to get better audio?

@Mark_Foley, welcome to the Community. While I don’t have an S9, I am wondering if you have an OTG cable to connect from the phone to the Dragonfly Red. Not sure if this matters, but Android and Samsung devices may require an official OTG cable to enable the phone to communicate with the DAC at different sampling rates.

I have several cables that were purchased as OTC cables. None of them have any effect on the issue. The output is still 48kH to the Dragonfly Red. I tested one of these OTC cables with a Flash drive to phone and it worked well to read files.

Hi @Mark_Foley ,

What does the Signal Path in ARC show? Did you disable the toggle in ARC settings that automatically selects the best quality, and force it to use the Original Format?

It shows:

Signal Path: High Quality,
Source: FLAC 192kHz 24 bits 2ch,
Streaming to ARC: Roon ARC Playback engine,
Bit depth conversion: 24 bits to 64bit float,
Sample rate conversion: 192 kHz to 48 kHz,
Bit depth conversion: 64bit Float to 24 bits,
Output: AAudio.

It makes absolutely no difference if I hook up the Dragonfly (Dragonfly light is colored blue) or without the Dragonfly, and makes no difference with the Setting of Best Quality or Original Format. It’s always the same Signal Path. I even refresh the song each time to try to get the best format.

Thanks,
Mark

Hi @Mark_Foley ,

Thanks for that info. Can you please try something? Can you use another app to play back 96kHz content to the DAC via your Android, make sure that the Dragonfly is the correct color for the higher resolution stream, and then switch back to ARC and try again? Android typically chooses to play at the last sample rate it received, so I am wondering if we can force the conversion to 96kHz this way.