Roon ARC on ipV6?

Roon Core Machine

LEAP 15.4 (OpenSUSE)

Networking Gear & Setup Details

T-Mobile Internet KVD21

Connected Audio Devices

Android Galaxy S22 Ultra

Number of Tracks in Library

Description of Issue

T-Mobile only uses ipV6. I have dyndns configured to use ipV6.
But Roon ARC cannot connect to my core. It worked on ipV4.

How does this work with IPv6 addressing and Privacy Extensions? Does your Core have multiple IPv6 addresses?


Roon core has a local ipv4 address. My router has ipv6 enabled, and port forwards to the core’s ipv4.

I don’t think there is IPv6 support as of yet based on the post I shared.

1 Like

Which is a shame because it would mitigate the NAT/port forward issues. This is precisely what ipv6 was made for…

1 Like

I believe Roon enabled IPv6 support for ARC however…

T-Mobile 5G Home Internet BLOCKS all unsolicited inbound traffic to your router. This prevents ARC from functioning.

What do you mean “it worked on ipv4”. In what configuration?

See this post:

Roon Labs marked this resolved and a couple of us verified that ARC Server will bind to the IPv6 address.

1 Like

Getting that the link above doesn’t exist or is private.

I’m in Ireland on Virgin Media who it transpires use IPv6.

Initially gave up trying to configure ARC when I learned this.

Is there a dummies guide anywhere on what to configure?

Not exactly and my network doesn’t support it so I’ve not successfully tested either. I know, and some have called me a “network engineer”. I’m working on it though.

The basics…
First you’ll need a client on an IPv6 network. This should be any modern phone on a modern cellular network.

Then, you’ll need to make sure your home network doesn’t block incoming IPv6. There is no concept of “NAT” in IPv6. That is, everything is routable. This means the client should be able to directly connect to your Core without any forwarding rules. But, of course, that means your Core can obtain a globally unique unicast address and your router / service provider is allowing inbound connections to that unicast address.

If your Core is running on Windows or something else with a GUI you can open a web browser and go to one of the IPv6 testing sites (like and it will tell you if your Core has a globally routable IPv6 address configured.

1 Like

That’s a great start.

Thanks very much for writing that out.

Hi @Aidan_Nolan,

Please accept my apologies for the long delay in responding here. According to other Virgin Media users, you can simply request a backend change for your Virgin Hub to prioritize IPv4. This may be available in your case - in the case of the user here, it was a simple phone call and a free account setting change. Here’s the referenced thread: Virgin Media HUB 2.0 [notes for Ireland users]

@James_Rome, unfortunately, as @ipeverywhere has mentioned above, T-Mobile 5G has implemented some inbound filtering on their residential-tier accounts that simply won’t allow for ARC to communicate with your Core. Please see this thread, where users have linked unofficial but successful workarounds: Is Roon ARC a No-Go for T-Mobile 5G Home Gateway Users? - #2 by Robert_F

Note that the team is actively researching easier workarounds for IPv6 support, so that Roon will auto-configure with IPv6 networks and certain common configurations of IPv4 tunneling with dual-stack lite. We don’t have a timeline or any details on this effort for now, but it’s a high priority to open up access to mobile playback via ARC to all our users, regardless of their internet service provider.


A post was split to a new topic: Glass Fiber Requires IPv6: Port Forwarding Fails

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.