Roon Arc problem connections

Roon Core Machine

Win 10, 11th Gen Intel(R) Core™ i5-1145G7 @ 2.60GHz 1.50 GHz ram 8gb

|—|—|Windows 10 Enterprise
Ver 21H2
Instal ‎07.‎09.‎2021
Kompilacja systemu operacyjnego 19044.1586
Windows Feature Experience Pack 120.2212.4170.0

Networking Gear & Setup Details

D-Link Dir-825ACG1

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Problem with connection, see below
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“178.217.197.41”,“router_external_ip”:“192.168.55.101”},
“status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}

I have NAT on, and

Protocol IP address Private port Public port Description
TCP 192.168.0.58 55002 55002 RoonMobile_broker/15e289da-c1aa-4068-a6c3-fb3fcf097eb5
<div data-theme-slick="1">

type or paste code here

</div>

“status”: MultipleNatFound

Have you set your ISP modem to bridge mode? Some ISP, like AT&T do not allow bridge. You need to go into firewall settings and enable IP passthrough.

I probably need to purchase a public ip address service from my internet operator

I would try Jason_Riggs’ suggestion first. If the double NAT is on your end, you should be able to alleviate this without any additional cost.

2022-09-27 21_31_52-DIR-825ACG1
In Firewall option IP passthrough not exist.