Roon ARC problem with Huawei

Roon Core Machine

Roon Nucleus with latest updates

Networking Gear & Setup Details

Huawei b818 263

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I need the exact settings for Huawei. So far I had no luck with any of the settings available, not even with or without UPnP.

The same as with many others:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

The Huawei is a 4g or 5g modem/router, I believe? Who is your mobile network provider?

Yes, 4G modem/router and ISP is Elisa Oyj (here in Finland).

Hey @Jussi_Arvio,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?


Hi and thanks,

The problem was on the ISP side and is now fixed. The public dynamic IP was not working and needed some TLC form ISP.

Now all is well and ARC is working like a dream :slight_smile:


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.