Roon ARC probs with ISP router and own Google Nest Mesh Network downstream

Roon Core Machine

Version 1.0 (build 254) production
Version 2.0 (build 1193) production
On Intel NUC computer

Networking Gear & Setup Details

On Ethernet, no VPN
Using ISP router, then the Roon is on a Google Nest Mesh Network downstream of ISP

Connected Audio Devices

3 x Naim streamers, Sonos x 3

Number of Tracks in Library

41.000 tracks

Description of Issue

Cannot confirgure roon ARC. I think I have set a static IP for the ROCK, and set port forwarding (have I done it properly?)
Error code is:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“138.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.86.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Thanks In advance!

Tim, welcome to the Community. As it appears you have two routers in your network, have you enabled UPnP on both your ISP router and your Nest mesh system? Alternately, de-activate UPnP on both routers and set up a port forwarding rule using the following guidelines:

  1. On your ISP router, create a port forwarding rule from the ISP router to the LAN IP address of your primary Nest mesh router (looks like it could be 192.168.86.1) using the port number for Roon ARC found in the Settings → Roon ARC tab

  2. On your Nest mesh router, create a port forwarding rule from the Nest mesh router to the LAN IP address of computer running your Roon Core (it should have a number similar to 192.168.2.aaa if the Nest system is using that address numbering method) using the port number for Roon ARC.

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Hi Robert. Thanks very much for your help.
I tried UPnP on both, they were both on, no luck.
I did the port forwarding. I had put the Rock IP on the main router not the google nest, I changed it but that didnt work either.
I had previously had a different main router, and the port forwarding had worked, but it has stopped since my new main router/new ISP.

  1. The main router is an ASUS AX6600 XT8, the 'internal one is a google nest with several points connected.
  2. Additional google points as above and several unmanaged switches.
  3. The ISP is Wessex Internet, and I am in the South of the UK.
  4. I dont think so / dont know. I havent set this. I have set the ports forwarding on both devices.

I really appreciate your continued help…hope you can sort this for me. Thanks

@Tim_Watkins, I also use an ASUS router, but have extended it using the ASUS AiMesh system. Can you please post a screenshot of the devices connected to your ASUS router under the ASUS administration page Network Map → Client Devices? You have two routers in your network and I am wondering how they interact with each other and what devices are seen by each router.

Hi Robert, thanks for continuing to help :slight_smile:
Is this the info that you need?


Thanks again

Tim