Roon ARC Quality Poor When Streaming 5G/LTE

I listen to Roon ARC while walking and I’ve noticed that signal becomes lossy after a while. For example, today I started listening to a 96 kHZ, 24 bit piece from Qobuz while still in my Wi-Fi network. Sihnal quality was fine as shown here:

After a few minutes walk I entered 5G land and a bit later the music briefly dropped out (less than one second) and when it came back the signal was lossy MP3 as shown here:

This has been going on for several weeks and once it goes lossy it stays there, regardless of signal strength or whether 5G or LTE. Today I shut down Roon ARC when this occurred and streamed the same piece direct from Qobuz. It stayed at 96 kHz for the whole walk (1.5 hours).

My portable setup is an iPhone 13 Pro feeding an iFi Audio xDSD Gryphon DAC/Amp that powers Focal Elegia headphones. Provider is Verizon Wireless.

My home setup is a Roon Nucleus connected to a Synology RT2600ac router and controlled with the Roon app on an iMac and iPad. All operating systems are the latest available. Provider here is Comcast Xfinity with download speed of 230+ Mbps and upload of 12 Mbps.

Have I missed a setting along the way? Or is this to be expected?

If you have it set to Auto it will change based on available bandwidth. It’s designed to be scalable based on the data bandwidth your device is getting. It tends to air on caution to stop dropouts and keep smooth playback. Just because your phone shows full bars does not mean you have high data rates nor does being on 5g. If you feel you can get a steady bandwidth to always stream hires then turn off Auromatically pick best quality and set it to original for cellular. But don’t always expect smooth playback.

You are partially right. I was streaming on 5G Auto and today I switched it to LTE only (admittedly, 5G is spotty in my area). As I transitioned from Wi-Fi to LTE on my walk the high res stream played on. While it lasted longer in LTE mode, eventually the stream slipped back to lossy MP3 at 44.1 kHz. At this point I switched over to Qobuz direct with the same high res piece. It stayed in high res for the rest of my walk (still in LTE only).

I’m not quite sure how Roon ARC works, but I’m assuming downloads go through my Nucleus which then get uploaded somewhere for wireless streaming to my phone. This is clearly a longer path than direct streaming from a Qobuz server. I tend to think there’s a weak link in the Roon ARC path that is causing this problem.

You miss understanding the setting I mentioned this is in ARC not your phone set it to the bandwidh you think you will get.

And no Qobuz comes direct from their api streams not via your core. And as I said ARC vias on the cautionary side unles you explicitly tell it not to. What are you using to gauge if Qobuz isn’t dropping bandwidth either.

I don’t think so, pretty sure it does not adapt to bandwidth. However, if the OP has it on Auto, like you wrote this means it is set to Original Format on wifi and Balanced (lossy) on cellular. (though it doesn’t dynamically adapt further according to cellular bandwidth)

I don’t understand the mp3 in the signal path though, it’s using Opus :man_shrugging:

It does from my experience when on auto. It will switch as and when bandwidth changes. This is why I fix mine to what I want.

If it’s from qobuz and you use the lower bandwidths it’s mp3 as that’s what their lowest format is. Opus is only used for local music.

I think this must be new then and not reflected in the so far unchanged FAQ. I’ve also never caught it doing that but who knows

Right, I forgot.

Note that it gives a fixed bandwidth for Balanced though

Not sure it’s new perhaps I remember wrong it was September when I last had it on auto but it’s no doubt the issue the op has.

Absolutely it’s the cause for the behavior seen by the OP
@Daniel_Blazej, all screenshots were from

They need to change its name as setting balanced all the time on auto for best quality isn’t the best quality to have two more above that. For me it is the most I can get as my data in London sucks big time at home it’s laughable so no cellular backup for me when internet is down.

True. I thought I saw a feature suggestion for or a discussion about adding adaptive behavior once but can’t find it now

Thank you both CrystalGipsy and Suedkiez, especially for pointing me to the appropriate location on the ARC FAQ page and your explanations. I agree that turning off the “Automatically pick best quality” switch is counterintuitive. But I’ve done that and now made both WiFi and Cellular “Original Format”. Since I’m paying Verizon Wireless through the nose for unlimited data I want the best playback possible. I’ll see how this goes on my next walk.

Regarding playback, the iFi Audio xDSD Gryphon DAC/Amp ( has an OLED screen that shows sampling rate, audio format, volume, etc. I just got this device a few weeks ago and it’s really nice (and British!).

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.