Roon ARC shows "Bad connection, with try again button" after it could already be used successfully before

Hello all,
maybe someone has an identical problem with ARC and can help here.
Thanks in advance…

Roon ARC can be successfully installed and used on two iphones initially. After several days ROON ARC shows after each startup the following message: “Bad connection. Try again or listen to your downloads”. With the Button: “Retry” → no connection to ROCK could be established. Restarting ARC or ROCK does not bring any improvement.

First after a reset of Roon ARC with a new login and synchronization, the message is no longer displayed and ARC can successfully establish a connection on the device again. Identical behavior on two seperate iphones.

Even if the error is currently occurring on one cell phone, ARC can be used successfully by the other after resetting ARC on this one.
The error message is displayed regardless of the current Data or mobile connection of the iphones. Other apps can successfully retrieve data (e.g. streaming). The error alredy exists before the last update of ROCK and ARC to the actual versions.

Roon ARC 1.0.28 (Build 106)

Mobile devices that run ARC

iphone 13, iOS 16.0.3,
ihone SE, iOS: 15.7

Roon Core Machine:

ROCK, Version 2.0 (build 1182)

Networking Gear & Setup Details

Router: Fritz!Box 7590 (Automatic port shares-successfully set up, no VPN) connected directly to the house connection. ROCK is connected via ethernet cable to the router (IP Address Setup: DHCP, IP Address not changed during the complete timeperiod)

I had this problem and uninstalling ARC and reinstalling it fixed it for me. Unfortunately you will loose any downloads you have if you do this.

Thank you for your comment. I have now done this (in Roon ARC reset to default, successful login and initial synch.) with one cell phone and can use ARC successfully here again, let’s see when this changes again…
With the second one I have not yet reset ARC and continue to receive the error message. The error message is also/still shown when the phone is in the LAN (Roon app works fine) but ARC not.

Is there a way to get more information about the error in ARC? Or just re-login instead of a reset that will lose the downloads?

Not that I know of. The Roon team could look at your diagnostics and that might give more insight.
You could easily try the re-login and see if that helps before reinstalling.

To re-login before reinstalling (Reset Roon ARC) would be a good possibility to find out if this would solve the problem. But I could not find a re-login possibility in ARC. In the “settings” area I could only see the informations of the roon core follwowing the actual “Sign in as…” but no possibility to logout or re-login.

Could you please tell me where I have the possibility of a logout or re-login in ARC?

Pretty much the same problem here. Used ARC for a few months without any problems, but last night it couldn’t connect. The connection to the Core was too weak. It didn’t even work at home. Thought maybe a port change was the cause but it turned out not to be the case. After a reset of Roon ARC, there was a connection again. So it could be OK. But now I see an error on my PC as well as on my iPhone SE 2022 and iPad Pro when I go to Roon > Settings > Roon ARC.
Roon ARC tests the connection but after a few seconds the message appears that Roon ARC was unable to access your Roon Core:


That’s weird because when I start the ARC app, ARC just works. This is how it is in my house. I wonder if it will work tonight during a train journey.

Me neither.

Outside my house Arc doesn’t function, there is no connection.
Port 55000 now doesn’t work outside but also NOT inside. My router setting for UnPnP is enabled and the IP address of my Core has an automatic portforwarding enabled for port 55000 but that doesn’t work in the end.
What have I done to solve the problem. I entered a new port number for my Core’s IP address: 55500. Now my mobile could connect through that port.

I checked my PC and wanted to enter the same port number there but it was already connecting on port…55000?

It works but I don’t get it. Is there an explanation for this?

Hello Bert,
after the connection problem was displayed on my cell phone in ARC and no connection could be established to the CORE, there was also no port change (Core). Now that I’ve reset ARC on one cell phone, I’ve been able to continue using ARC on it ever since. The phone that hasn’t been reset keeps showing the message and can’t connect. So far, no error message has been displayed in Roon during the ARC/CORE connection check.
If helpful, I could provide more information on the ARC error to Roon Support when they get in touch and to also show other users with the same problem a possible solution?

Hello Marcel,
Adding a new port number (55500) on my router and mobile devices/PC was needed to play again music outside with Roon ARC. So I don’t use the recommended port by Roon anymore (55000). Why this port number is suddenly useless I still don’t know.

Hello Bert,
thank you for your feedback and a possible solution, I will try to change the port and see if this solve the problem with ARC on the one handy with the connection problem and if this impacts the other one or other devices without a problem…
Best regards,
Marcel

Hey @Marcel_Byron,

Ben with the support team here, I wanted to check in and see if you were still running into issues with Arc on one of your mobile devices? If so, can you share the make and model, and recent error message you see on your Roon core settings > Roon Arc?

I’ll be on standby for your reply :pray:

Hello Ben,
thank you for your response. The Roon-ARC error message on one mobile device (iPhone 13, Modellnr.: MLQA3ZD/A, iOS-Version: 16.0.3 (20A392)) is still displayed directly on the Roon ARC screen after starting as shown in the first picture. The Roon-Core shows “Ready” (no error message) and works fine with all other devices (Roon-ARC via W-LAN: Two different Samsung tablets & BlueOS speaker, one via ethernet connected Lumin) Core screenshots attached. Even if the Roon-Core is turned off, this error message is displayed on the iPhone 13 and not “Can´t connect to your Roon-Core” (core last seen x days ago) as “normal” on other devices.

On the second iPhone SE which worked for weeks since the “Reset Roon ARC” selection in december 2022, today also the same error message is displayed again and can no longer be used (see first screenshot). I have not changes anything on my own in ARC or on the core (except for updates). Could a port change be the root cause? I don´t know if it changed from today to december.

Best regards,
Marcel



Hey @Marcel_Byron,

This would make sense. For Arc to work, it’ll need a constant connection to your Core which would need to be online for that to happen.

If you remove and reinstall Arc on the problem iPhone 13, do you still run into issues? It’s odd that Arc is functioning properly on a handful of other devices, yet causing issues on one specific device.

Please make sure you are up to date on both Arc version, and Roon core version while you re-install Arc on the device :+1:

Hello Ben,

right, but based on the turned off Roon-Core and the ARC error message “poor connection” I would expect that the message “Can´t connect to your Roon-Core” will be shown. This seems to me that ARC didn´t even know that the Roon core isn´t available. Is it possible to provide you some more informations from ARC that you have more insides behind this error message (log file or screenshot from an internal arc status view)?

Even when I’m up to date with the Roon software on all devices the ARC connection problem will be shown after several weeks in which it worked until then without problems. Only after a “Reset Roon ARC” it works for several weeks (last period: ~1 month). Actual the ARC connection problem is shown on both mobile devices (iphones) and could’t be used. Even when I’m switch off the mobile connection & they are only connected via wlan, ARC shows the same connection problem. On the same devices, the Roon software could connect to the Core & could be used without any problem.
Best regards,
Marcel

Hey @Marcel_Byron,

Thanks for the info. The next thing we’ll need is a specific timestamp of the date and time the next time you run into this issue.

I would also confirm that the port numbers from your Roon core align with the port numbers being used on your router. Reviewing this thread, have you tried updating your port number as a test as well?

Do you also have connectivity issues on the iOS device when using it as a normal Roon Remote? Or, does this only occur in Arc?

Hello Ben,
today I also reset the Port number via Roon Remote successfully, but the error message in Roon Arc on the cellphones unfortunately still remain. I checked also the configuration on the Router (Fritzbox 7590) but no error messages in the logs, the option: “Allow independent port forwarding for this device.” is enabled (in synch with Roon port) & the network device “Rock” will always be assigned with the same IPv4 address.
On all devices including the iOS devices Roon Remote could be used all the time without any problems or errors.
Today I have “Reset Roon ARC” within one iOS device and the other one remain with the error. After the reset, login & a successfull connect to the core (Syncing with Roon Core for the first time…, Who is listening today?..) Roon ARC works fine and could be used (27.01.2023, 18:10 o’clock).
From today I will try to connect each day with ARC on this device to the core to have the day when the error will be shown again… as soon as the error shows up, I’ll write again…
Best regards,
Marcel

1 Like

Actual Roon ARC Version: 1.0.30 build 128
Roon core version: 1.0 build 254