Roon ARC stability issues

Roon Core Machine

Win 11 22H2 on headless/fanless server. Intel i5-11400, 32Gb RAM, 250Gb m.2 system drive and 10Tb media HDD.

Networking Gear & Setup Details

FMC into Asus RT-AX58, wired Core.

Connected Audio Devices


Number of Tracks in Library

200K tracks

Description of Issue

Roon ARC seem to cause havoc on my Core… And the App is consistently psycotic on most devices. When i have use for ARC, as in “away from Roon Core” it always seem to go tits up…
I used ARC this morning when travelling (in the car, working fine) and now in the evening i decided to use the iPad rather to play back some music. Of course the ARC app had a fit and to maintain sanity i first tried resetting ARC… No go, like always… remove ARC, reinstall it, log in and initiate sync with my (available) Core.
Viewed some web pages while waiting and when i came back to ARC it had stopped syncing with a genereic error in vein of “sync failed”.

hmmm… Took up the iPhone where ARC was running fine in the car this noon, and tried that. No go, of course “bad connection” et al.
So once again, i can only conclude that ARC usage messes up my Roon Core somehow.
I have no stability issues whatsoever when using Roon locally, on my LAN/WLAN. The server usually runs for moths between restarts, and never due to malfunctioning Roon, just Windows patches…
Use ARC for more than a couple of hours and the Core (or at least the ARC functionality) will seize up.

To me this IS the usual behaviour of ARC and it makes the function pretty useless.
Especially as any downloading to the devices takes a freaking eon to complete, even on a perfect WiFi6 network at home.


Sorry @Mikael_Ollars I can’t add anything positive as I finally uninstalled ARC 3 day’s into my holiday as it had crashed the core 6 times.

There are already a couple of thread’s complaining about ARC stability but it doesn’t look like Roon support are taking an active participation in any of them


Me too, I got fed up on Arc quitting on me mid commute in the car, I just use the Tidal app now or Plexamp, both are reliable.
I love roon in the house, but that’s it.


ARC seems to get stuck in this mode, when this happens:

This is from the iPad who’s initial sync failed…
To fix this, it seems i HAVE to reinstall the app but there’s no point in that now, as i haven’t got access to the Core.

And this is what i get from Roon Remote when back home:

Timestamp top left in CET…
I’l reboot the Roon Server now, and restore functionality…

I’ve never had to reboot the server to restore Arc functionally, normally stopping the app, clearing all caches, basically resetting it to the beginning used to work.
I’ve not tried the most recent build, I realised I didn’t actually need Arc so I will not use it.

ARC is a lesson in „be careful what you wish for“…


This is affecting a lot of people apparently, here is the oldest thread about it:

Has been an issue for a while, unfortunately


I’ve come to the realization that ARC was a really good idea, and nothing more.


Roon ARC has been unreliable pretty much the whole time its been around for me, but this past week its been basically completely unusable. It keeps absolutely obliterating my roon core.

device connection

Core connection
Screenshot 2023-10-08 202226

It’l act like its connectable

Then itl do this

Then itl rotate between this and green

This will also make my local devices using remotes inaccessible and will not be resolved until I restart the roon core.

My network security hasn’t changed, the proper port is open, I can stream 4k full BD rips on my plex when this is happening, I can easily stream music using the Qobuz app. This is 100% an issue with Roon ARC nuking the roon core somehow and it needs resolving as atm roon arc is beyond unusable.

ARC worked for me initially, then it failed, I reinstalled it and tried to sync, it failed, I reinstalled again and it worked but wouldn’t download any of my playlists for offline use.
I have deleted the ARC app now, as @mikeb said “Arc is a lesson in be careful what you wish for”
I use Apple Music when I am out and about, works every time.

Thanks everyone, for input, and “data points”.

Thing is, i just LOVE ARC when it works, but unreliability is the worst possible property i can imagine for a product like this, and i would care less if it only offered my latest 3 dozen albums added, or only 256Kbps AAC resolution or whatever.

And i have just finished reinitializing ARC on the iPad. I was forced to yet again remove/reinstall the app as it was completely fecked up…

And then comes the “ever annoying” redownloading.
Somebody complained that ARC behaved like a “petulant child, needing constant attention and surveillance” and that analogy is very fitting.
It needs desperately better background handling, a bit rate conversion and lots of tuning of the current behaviour. I mean, i am not very interested in downloading DSF or high rez content to the phone or iPad, CD Rez is just fine for keeping storage within bounds. And when on WLAN i can stream this content in original format through the attached USB DAC. Point is, let us choose download quality!


I refuse to beta test or maybe actually alpha test a software program I’m paying for. No one would put up with uapp acting up like this for a year.

1 Like

I agree completely I won’t be bothered to fight to use ARC. I have other means to use my phone via cellular. Qobuz and Onkyo player work extremely well in my usage. I really hope that Roon users being intelligent and mature will not be trying to troubleshoot ARC issues while operating an automobile. Distractions while driving is just not worth it.
That being said, what is the most effective way to disable ARC fully on my core that is installed on a MacBook Pro? My goal would be to eliminate any overhead and security concerns.

1 Like

In Settings, set the ARC port to zero.

1 Like

Done, thanks Mike that seems to have worked. ARC really should have a Off or Disabled switch on it’s settings page perhaps.


I give up with ARC, roon remote via VPN works just flawlessly, just the AAudio bypass is the last thing to fix.

Overheating my tablet unnecessarily, because big libraries seems to be a problem in ARC, not in REMOTE.

I’m new to Roon and I’ve spent the last 2 weeks plus figuring out, with help from this board, but not from support - how to solve the problems just loading Arc to my phone. Finally got it loaded yesterday only to find out the app is not working where streaming services are. On and off, long downloads, in short, useless. How unfortunate that such a well designed interface for enjoying music is so flawed and user unfriendly in its operation - Arc has been the most troubled app I’ve ever tried to work with. I see I’m not the only one who is frustrated. The price of the subscription is quite high for almost non-existent support. I can imagine how you must feel after paying 1500 for the server.


Official thread for ARC issue investigation:

Well while the current ARC unreliability and recent scarcity of Roon support is regrettable, I do think that it’s worth mentioning that the login issue was not the fault of ARC as such. Many apps use browser-based logins these days, and forgotten cookie blockers do interfere with all kinds of things, to be fair :slight_smile: Maybe the sign on process could be less vulnerable to this and I brought it to the attention of the Roon people