Roon Arc still not working…Help!

Roon Core Machine

Roon Core - Windows 10 running on a 12 core HP xeon server with 96 GB RAM running Roon 2.0

Networking Gear & Setup Details

Network - Unifi Dream machine pro + US-24-250W Switch

Connected Audio Devices

Mac mini running Roon bridge connecting to the DAC via USB .

Number of Tracks in Library

Description of Issue

I was quite excited about Roon 2.0 with Arc . I reinstalled everything to the new updated apps but ARC is not connecting . I also upgraded my NBN connection to a static IP , I also manually created a Port forward but still Im getting the following error .

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:””,”router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I replaced my IP address with ‘Xs’
I did follow the recommendation of Roon on manual port forwarding.

IP address: The IP address of your roon core
LAN/Private/Internal Port: Port 55000
WAN/Public/External Port: This port must be the same as the LAN/Private/Internal port

But still the error remains . Any help would be appreciated from the support team .

Probably a screenshot or two of the port forwarding setup would help.

1 Like

if you have NORTON or similar suites controlling basic windows firewall … you need to ‘open port’ there also … my own experience

Thanks mate , Here is the screenshot

Thanks again , I don’t have any Antivirus running except for the windows defender.

The NBN modem is the one which is provided by NBN and is a HFC format and If im not wrong the brand looks very much like the Arris Touchstone CM820.

Why are you forwarding port 55001 rather than 55000?

I tried 55000 too , same result .

You can use any port in the dynamic/private port range (49152 - 65535). In fact, it might be considered a good idea to use a port number not everyone else is using…

Hey @Emmanuel_Charles

I can’t believe that no-one from support has come along to help you yet.

I noticed that even though I tagged them twice in your first thread about ARC that nobody has yet responded.

I hope you can get it sorted out!

1 Like

What is this plugged into?
Who is your isp?
Did they supply you a router as well?

Hey @ipeverywhere this is from Emmanuel’s post above and he is with Optus in Australia.

If you go to:

Does the IP address match the static address your ISP gave you?

Restart your Roon Core may help. My Roon ARC worked straight away after installing from the iOS App Store, but yesterday it stopped working all of a sudden, restarting the Roon Core fixed it.

Thanks for that.

I’d verify on core the port set. Then verify that’s the port on the dream machine in the forward rule.

Then try ARC. Don’t worry so much about the error. If the port is set then it’s listening for a connection at that port. If the forward rule works then it might just work even with that error.

Hi Mate , The NBN line comes into the property via HFC . That goes into the NBN supplied modem perhaps the Arris Touchstone CM820 , The modem is connected to the UDM pro and then to the US-24-250W Switch . Every connection to the house goes out from the US-24-250W Switch . The ISP is Optus and I also recently upgraded to static IP . I think they did supply me with a router from optus , but I use the unifi eco system… Cheers, Emmany

My IP address is the same one which the ISP gave me . So definitely its a static IP .

Hi Mate , I restarted the core many times , its the same error .

Hi Mate , I feel the same way , its a premium priced product and I was so excited to jump on board with the introduction of ARC and I haven’t heard from one support team member yet. I’m pretty sure they are all busy , but just acknowledging my issue and looking into it eventually would be just great . Thanks again for all your efforts mate . Cheers

OK, if you are familiar with command line, you can check by telnet “your roon core ip4 address” 55002 (assuming that you use the default port)? All is OK if port is opened and is listening for connection.

For example:

% telnet 55002


Connected to

Escape character is ‘^]’.


telnet> q

Connection closed.

But I guess it may be a bit complicated for non-software people?

1 Like