Roon Arc - still not working

All, sorry I have been beyond slammed in my personal and work life. someone started to respond to me, but it timed out after 45 days. I think I have more time now, but still no clue where to help. I am hoping my procrastination works to my advantage in that you have more information now that before.

Here is the diagnostic copy/ paste error:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

I can also tell you have Centurylink modem and using orbi system to extend the network mesh into my home and yard.

Hi Karl,

I moved your post to the appropriate support thread. Please review the following and fill out the information so that when support engages it will have the necessary information.


Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

if I knew all that stuff, I would be much less likely to be reaching out at this point. are people contacting service technicians as a solution? because I really do not know most of the stuff you are asking about. everything I have set up at the house just worked automatically, I have no idea how to configure this or that.

Modem: CenturyLink technicolor C2100T


Other than using UPNP you could set the port forwarding manually. Make sure the port matches the value in the Roon ARC settings.


not sure if I did that right, but not my area of expertise (didn’t work - still fails)

Router config looks ok. The Roon core is on a PC/server/laptop? As hinted above - any FW in operation you could, at least temporarily, disable for testing ARC?


Windows FW? Any additional Windows security software?

that is under 'IPv6 Firewall" settings - there is also a IPv4 settings page, but it lists a ton of services or whatever that are all checked (meaning they are allowed according to the instructions on page)

Router config looks ok. The Roon core is on a PC/server/laptop? CORE IS NUCAs hinted above - any FW in operation you could, at least temporarily, disable for testing ARC?

And pls do not disable the router’s FW. At that end port forwarding is what we need and have. Don’t put yourself at risk.

I disabled it temporarily - no difference.

as mentioned previously, I have ORBI to extend my network. Not sure if that is playing a role. Only thing I have noticed is the ‘bridge’ mode but based on description I doubt I have that setting.

Bridge mode refers to the modem (if you have separate devices as often the modem and router are a single device).

It could be helpful if you provided a network description of your home as far as Roon is involved. So router → mesh(?) → NUC ?
Do you have a single subnet (like 192.168.1.x) or are there more?

technicolor C2100T → RBR750 → NUC (not sure of or how to retrieve details on this)

Pls check wether the ORBI is in bridge mode. In case it uses another subnet (say the C2100T lives on 192.168.1.x and the RBR750 adds another like 192.168.100.x for his clients) you would need another port forwarding.

Specifically a PF from the CT to the RBR and another from the RBR to the NUC. As said only(!) if there are multiple private subnets.