Roon Arc Stuck at homescreen

Hi Guys ,

Recently Roon Arc asked me to log in again, and when I did it got stuck in the first page, where it usually asks " Who’s listening today?" . I do have my own profile and for my wife and kids another one . I tried waiting for something to happen but its still there in that page . Im attaching a screenshot too . Any takes?. Cheers Guys .

I’m getting exactly the same problem and can’t get beyond it.
Really not good that you’ve had no reply from ‘support’ in all this time.

Try uninstalling arc and then re-installing it. Seems to fix a few problems doing this such as the recent error of a poor connection message.

Hi @Emmanuel_Charles, @Ian_Galbraith

If you’re using an Android phone, try installing ARC from the .apk installer on our downloads page (instead of through the Play Store):

If you have an iOS device, then try fully deleting the app and its data on the phone before reinstalling. Additionally, I recommend you refresh your Roon server to avoid any potential authentication mismatch and to verify you’re on the most updated build:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Hi Connor , I did a fresh install of roon on my linux server . So when the library is empty , Im able to access roon via Roon arc without isuues , but when I did a backup restore of my library which is quite big with about 700k songs , Im not able to access roon via Roon arc , Im getting the same error . So I dont know what the issue is , its kind of a conundrum . Any help to solve this issue would be just splendid . Thanks again . Emmany

There was or is a known issue with ARC not connecting after restoring a backup on the Core. I reported this in earlyaccess at the end of January and the topic is now marked as resolved, but I don’t know if the current production version already has the fix. Possibly you are still experiencing this and in this case it will hopefully be resolved soon

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.