Roon ARC Stuck on Logo Screen

Happy new year!

I tried again to reinstall the app, but the situation is still the same, stuck in the Arc-logo…


I installed Roon Arc to another phone, OnePlus 7 with Android 11.

In that Arc starts normally and works fine.

But still Arc is stuck in the Arc-logo with the OnePlus 9 with Android 13.

Hi @Sebastian_Wallenius,

Reopening this thread to check in on the status of your OnePlus 9. Are you still encountering sync and login failures?

If so, we recommend installing ARC from the Android APK downloader instead of the through the Play Store. Note you’ll need to manually update each release if you use the APK installer - however, this workaround ought to prevent hanging on the login screen.

Here is the download link for the Android installer:

Hi @connor,

I basically started using the OnePlus 7 with Android 11, because that seemed to work fine.

Few weeks ago I once again reinstall the ARC app to the OnePlus 9 with Android 13, and somehow it just started working.

Thanks, I will install the ARC from the Android APK downloader if the problem happens again.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.