Roon ARC: "There's an issue that's preventing access"

Roon Core Machine

Intel NUC11PAHi5 16 GB RAM
Ubuntu Server 22.04.1 LTS
OS firewall is currently disabled

Networking Gear & Setup Details

Netgear Orbi RBR50 (supports UPnP)

Connected Audio Devices

Schiit Bifrost 2 via RopieeeXL / RPi4 → USB
Schiit Modi via RopieeeXL / RPi4 → USB
Apple HomePod via AirPlay

Number of Tracks in Library

25738 tracks

Description of Issue

Hi, I’m trying to configure Roon ARC. In Settings, it says “Your Roon Core was automatically configured and has been confirmed to be securely accessible by Roon ARC.” Great! When I run the Roon ARC app on my iPhone, it appears to sync properly with the core, then asks me who’s listening. But when I click on my name, I get the following message:

“There’s an issue with your Roon Core. Your Roon Core is online but there’s an issue that’s preventing access. Go to the Roon app for more information.”

The only option I’m given is to “Reset Roon ARC” (which I tried, but then got the same issue).

Unfortunately, when I go to the Roon app, I don’t get any more information; the Roon app (on both my desktop and my phone) appears to work as expected.

I always try to debug things myself first, but in this case, all I have to go on is “There’s an issue” … so I’m not sure where to begin. Thank you!


Update: I’ve now tried this two different ways - using UPnP for port forwarding, and manually opening a port in my router configuration. In both cases, the Roon app says “Roon ARC can securely access your Roon Core”, but the Roon ARC app says “Your Roon Core is online but there’s an issue that’s preventing access”.

The troubleshooting resources all seem focused on how to get port forwarding working. But in my case, it seems that port forwarding is working properly, but something else is preventing Roon ARC from functioning. Please help…


Ok, I got it working!

I recently moved my core from my iMac to an Intel NUC running Ubuntu.

Somehow, both cores were logged in simultaneously. I believe this shouldn’t be possible, but both cores were running and the new one (on the Intel NUC) was working great using the Roon app locally. But Roon ARC was presumably failing due to some authentication error.

When I rebooted the NUC, Roon complained about the “zombie” core on the iMac and asked me to deauthorize it. After that, Roon ARC worked fine.

I’m not sure why I had to reboot to get the deauthorization request, but I’m glad things are working now!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.