Roon ARC unable to access Roon Core

Roon Core Machine

NUC10i7 with Version 1.0 (build 227) OS.
Software Roon Version 2.0 (build 1128).

Networking Gear & Setup Details

ISP - Australian Vodafone FTTP NBN Modem
Roon Core connected via Ethernet to Router - Asus RT-AX88U with Static IP assigned and configured to Port Forward (configured static IP and specific port)
No additional hardware, VPNs, proxy servers, or enterprise-grade security.
Note - can access AppleTV (as Home) and Synology NAS which are both set up with static ip via internet.

Description of Issue

When trying to set up ARC I get “Not Ready, Roon ARC will not be able to access your Roon Core” with the following diagnostics:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“101.112.255.217”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Please help

I have the same issue
ISP is Act Fibre
Roon core 2.0 on Mac Mini circa 2014 with latest MacOS
Router/modem is Orbi RBR750 with updated software.
Does not connect to RoonARC though settings page in UPnP shows the port correctly identified.

{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“49.205.229.236”,“router_external_ip”:null},
“natpmp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

Need to get this fixed please

Same issue

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“202.22.228.31”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}

Same error here.

AT&T Uverse router with Netgear Orbi.

Same issue for me. I have a similar set up as Vic-Almada and the same error message as @aloke_gupta

Roon Core
Only I have a NUC 11 PAH i3 that is running audiolinux. I have confirmed with the vendor that this is not stopping ARC from connecting.

Telecom provider: Singtel

Router: Asus GT AX-11000.
It has a wired lan connection with my Roon Core on the NUC. Port forwarding is enabled on the router.

My error message is
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“101.78.83.135”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Hi Allard, my problem was solved by getting a fixed up address from my service provider (at an extra charge). I think a call to Singtel saying port forwarding is not working should get you the solution. My ISP instantly know the issue and solution as I think many gamers have faced these issues. Good luck

1 Like

Thanks Aloke_Gupta, for advising me to call Singtel. It turned out that my Asus router should be set up as an Access Point (AP) and my Singtel Optical Network router also needed to allow port forwarding. Once both were changed, Roon could test ARC successfully. Now Roon ARC is working.

1 Like