Roon ARC unable to access Roon Core

Roon Core Machine

NUC10i7 with Version 1.0 (build 227) OS.
Software Roon Version 2.0 (build 1128).

Networking Gear & Setup Details

ISP - Australian Vodafone FTTP NBN Modem
Roon Core connected via Ethernet to Router - Asus RT-AX88U with Static IP assigned and configured to Port Forward (configured static IP and specific port)
No additional hardware, VPNs, proxy servers, or enterprise-grade security.
Note - can access AppleTV (as Home) and Synology NAS which are both set up with static ip via internet.

Description of Issue

When trying to set up ARC I get “Not Ready, Roon ARC will not be able to access your Roon Core” with the following diagnostics:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“101.XXX.XXX.217”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Please help

2 posts were split to a new topic: Act Fibre / Orbi network

A post was split to a new topic: 504 Did not find UPnP service with WANIPConnection on network

A post was split to a new topic: ARC AT&T Uverse with Orbi error

2 posts were split to a new topic: Singtel ISP / Asus GT AX-11000 Router Port forward help

Hi @Vic_Almada ,

Apologies for the delay in getting back to you here.

Does this mean you have a static IP from your ISP provider or is it a Reserved IP to ensure Core does not change IPs?

Are you able to configure port forwarding on the Modem as well? Does configuring it there solve the issue?

Hi Noris,

Thanks for getting back to me.

The static ip and port forwarding was set up via my router ‘Asus RT-AX88U’. Same as I did for external access to my NAS and AppleTV. As far as I can tell they have never changed.

Can’t seem to access my modem. I tried getting access to my modem and the ISP (Vodafone) were useless and had no idea how to access it. Couldn’t even tell me its IP address.

Hope you can help further.

P.S. - Have gone through multiple threads and the links provided and checked what was suggested. Still have the same error.

Hi @Vic_Almada ,

Thanks for that information.

I’ve been doing some searching and it looks like Vodafone NBN might use CGNAT in their networks. Would you please be able to ask your ISP if they use CGNAT and if they do, can give you a dedicated IPv4 address?

Hi Noris,

I have wasted several hours and tried on 3 seperate occasions to talk with my internet (NBN) provider which is Vodafone Australia. The level of incompetence from their call centres (mainly offshore) is astounding. Every operator had no clue what CGNAT was and apparently their escalation points also had no idea. To sum it up, they basically stated they do not use CGNAT and that they do not provide dedicated IPv4 addresses or Static IP’s.

Having spent hours trawling through your forums, it is clear the implementation of Roon ARC should’ve been a lot simpler. As stated previously, I have no problems setting up remote access to my NAS and AppleTV (Home) and am struggling to understand why this is unnecessarily complicated. Surely there is a way to get this working??? Or at least a simpler product to implement without needing an IT doctorate.

Love Roon as a product, but Roon ARC has really missed the mark.

No thanks to the technical support on this forum, I found the solution to my specified problem.

Basically all I needed to do was turn on UPnP on my router and it now works. If you have it on, then disable UPnP and re-enable UPnP and it might end up solving your problem.

Good luck all.

The very first suggested steps are put on upnp and check it’s on…

  • Try turning UPnP or NAT-PMP off and then on – this may resolve the issue on some routers or networks


Fair enough.

But this was not there when I first reported the issue and for quite some time after.

The page has clearly been updated since I last looked at it - as it should be.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.