Roon ARC Unable to Connect Outside Home (ref#N4UY29)

Affected Product

Roon ARC

ARC Issue Category

Can’t connect outside the home

Description of Issue

Roon ARC worked liked charm, but since the last update of both Roon Core, Roon and Roon ARC, Roon Arc is not accessible outdoors anymore. Roon gives the following Error when testing the connection:
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“62.ddd.eee.fff”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
The strange thing is that Roon sometimes “sees” that upnp is anabled (which is the case) and sometimes not. Roon also sometimes indicates that I have multipleNAT. I have only one modem/router however and have also tried by turning of my wifi extenders without result.
I have also triedmanual port forwarding, but again without result.
I have a Nuclues Roon Core, which I have set to static IP, without result.

Roon Core Platform


Roon Core Specifications

Nucleus, 2TB - about 6 months old, no connected external drives. The Nucleus works well.

Connected Audio Devices

Dutch&Dutch 8c (which work well)

Home Network Details

The Roon Core is connected by Ethernet. I use a Genexis Platinum 7840 modem/router.


Hi @Jan_van_der_Meij1,

Thank you for your post and for your patience while we worked through the queue to reach your inquiry.

First off, I recommend trying out a few different port assignment numbers in both the Roon → Settings → ARC page and any matching port forwarding rules you’ve created. It’s possible your ISP or some third-party software has recently reserved the port range Roon is attempting to use.

Secondly, it’s worth inquiring with your ISP if they’ve recently implemented any changes related to carrier-grade NAT or IPv6 (since you’ve seen intermittent multipleNAT lines in diagnostics despite having one active router).

Lastly, we’ve noted that the external address visible from our own server diagnostics does not match that presented by your ARC diagnostics above. Do you have any VPNs active, or proxy servers? What about other network security? Any ISP-provided modems?

Dear Conner,

I have assigned a port assignment further away from the 55000 range (11000) and that solved the problem. Thanks for your help.

Kind regards, Jan

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.