Roon ARC unable to connect

Roon Core Machine

Roon Core machine: Lenovo Y70 Touch,Intel(R) Core™ i7-4720HQ CPU @ 2.60GHz ,Win 10 Home 64bit,Ram - 16GB

Networking Gear & Setup Details

Nokia Router, On Wi-Fi , No VPN usage.

Connected Audio Devices

Home Pod-Airplay

Number of Tracks in Library

1500 Tracks

Description of Issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“171.ddd.fff.ggg”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Add images

Previously it was roon ARC was successfully connected suddenly it is showing error Roon ARC is unable to securely access Roon core.

“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“182.ddd.eee.fff”,“actual_external_ipv6”:“2401:4900:XXXX:XXXX:XXXX:XXXX:d21c:fd6e”,“router_external_ip”:“182.ddd.eee.fff”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Hi @Abdul_Basheer ,

Welcome to the forum!

This is referencing an IPv6 address. Can you please clarify how IPv6 is used in your setup? Who is your ISP provider and what kind of networking gear do you have (model/manufactuer)?

Thankyou for replying,
IPv6 configuration is set to automatic,
ISP provider - Airtel,
Router - Nokia (Manufacturer),G-2425G-A(Device Name).

Hey @Abdul_Basheer,

Can you please disable IPv6 and test running port forwarding with IPv4? Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both? * Is your router firmware up to date?

We disabled IPv6 it does not seem to fix the issue,
The modem is not configured in bridge mode it is forwarded on both,
The firmware of router is upto date.

Hi @Abdul_Basheer,

Now IPv6 is turned off, i would also turn off UPnP and create a manual port forwarding rule.

First in the Roon App under Settings → Roon Arc write down the ip address and port number shown there.

I hope below video will help you with creating the rule.

Let us know if it works.



1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.