Roon ARC was unable to securely access (Error: connect ECONNREFUSED )

Am using the Innuos Zen Mini as my Roon Core.

Router is a Linksys MX4000. No switches, no other hardware. Just the usual router and a mesh wifi.

Have tried the UPnP and it was already enabled so that didn’t work. I tried manually inputting the port forwarding, but that does not work either. The following error message below showed up.


“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 103.ddd.eee.fff:55000, response code: undefined, body: undefined”},

“external_ip”: {“actual_external_ip”:“103.ddd.eee.fff”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}


Hi @Sandy_Lim,

I would suggest you create a manual port forwarding.
First in the zoon app under Settings — Roon Arc write down the ip address and port number shown there.
Watch below video and try it. Hope it helps.

Kind regards,


Thanks. I had already tried that when I had submitted the earlier post. But the same error occurs.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Hi @Sandy_Lim,

There doesn’t appear to be a port mapping conflict in the diagnostics you’ve shared, so as @Martin_Webster mentioned, this 502 error is likely the result of either network security or an issue with UPnP.

A few additional troubleshooting steps you can take:

  1. Disable any VPNs you might have active and double-check exceptions for firewalls and antivirus software to make sure they include Roon’s protocols
  2. Verify the Linksys firmware is up to date. Outdated firmware can automatically disable UPnP on certain routers.
  3. You mentioned a mesh WiFi network. Double-check that you don’t have multiple subnets active and that you’ve created an identical port forwarding rule to that in your Linksys web administration on any other router-capable device on this network.
  4. If you have multiple ethernet ports on your Linksys router, try using your Core on another port. Sometimes, routers will disable certain protocols and features on certain ethernet ports. It’s worth a try.

We’ll be standing by for your response - please include any details prompted by our moderators that you haven’t already mentioned to expedite troubleshooting. Thank you!

Yeah, I don’t have the problem of VPNs or Firewalls being active. I’ve also checked with my router manufacturer and by default, there’s no firewall installed. It also already allows for VPN pass through, not that I have any VPN enabled.

I’ve also created the identical port forwarding and I don’t believe there’s any multiple subnet active. The error code again is this and if there are any multiple subnets, this should have shown up?

Lastly, I’ve switched the ethernet port too but also, that doesn’t work.

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 103.ggg.hhh.lll:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“103.ggg.hhh.lll”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

A post was split to a new topic: Cannot Download Playlists