Roon Arc will not be able to access Roon Core

Roon Core Machine

Mac Mini M1, 2020 16Gb RAM
MacOS Monterey 12.6

Networking Gear & Setup Details

Modem: Huawei EG8120L5
Router (Wifi): TP-Link Deco M9 Plus (Mesh)

Country: Brazil
City: Santana de Parnaíba
ISP: TV Alphaville (Fiber 300Mb)
UPnP Enabled
No VPN, proxy nor enterprise grade secutiry
Firmware updated
Roon 2.0 (build 1133)
Roon Arc 1.0 (59)

Connected Audio Devices

Denon Receiver AVR S750H
Google TV

Number of Tracks in Library

1,085

Description of Issue

I am having a hard time trying to connect Roon Arc to Roon Core. I already tried to follow the steps mentioned in the community (Unable and enable UPnP, Restart Roon, Create Doors Manually, turn firewall off, norton antivirus off, etc).

Could you please help me figure this out?

Please find below the error message I keep receiving.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“177.aaa.bbb.ccc”,“router_external_ip”:“192.168.18.3”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.68.1”,“found_upnp”:true}
}

Looking forward to hearing from you.

Thanks,
Gustavo

Welcome to the community, @Gustavo_Emerick.

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly. It also looks like you have double NAT with the Huawei (modem/router) and TP-Link (router).

Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridge mode and if not, try to place into Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thanks!

Thanks, @Martin_Webster!

It does make sense what you have described. But unfortunately, I have tried to follow the above four steps 4 times without success. I could be missing details here as I am not tech-savvy and this is the first time I am trying to solve this type of problem. So I am tagging @support for a better understanding of my case.

So I definitely need some support here. As you suggested, the info you requested is below:

1: Modem - Huawei EG8120L5
Router (Wifi): TP-Link Deco M9 Plus (Mesh)

2: No.

3: TV Alphaville, São Paulo (Brazil). Fiber.

4: Not sure, as you have detailed the steps above and I tried to put it in Bridge Mode, correct?

Anything else? Thanks once again.

Hi @Gustavo_Emerick,

Thank you for your patience in awaiting an official response. I’ve seen this issue pop up with the Huawei devices before. It seems you may need to set up forwarding on it to make this work. The unit serves as a router so when you’re using a router of your own, you have two!

Ideally bridge mode is what you want since we don’t want that unit doing the routing alongside your mesh setup. Some people have had issues with getting bridge mode working and this applies to ISP’s and modems around the world. That said, there are some instructions for setting up port forwarding on a SIMILAR modem/router combo. Perhaps it will have the steps you need to set this up. I will link it below. Alternatively, you might even reach out to your ISP and let them know exactly what you’re trying to accomplish. Chances are, port forwarding is something they’re using to hearing from people on.

Let me know!
Wes

1 Like