Roon ARC will not connect (UDMP w/ AT&T Gigabit Internet)

Roon Core Machine

Roon on Windows 10
Ryzen 7 1700 - AsRock X370 Taichi mobo
32GB DDR4
2x 4TB SSDs in software raid (Stablebit Drive Pool)

Networking Gear & Setup Details

ISP: ATT gigabit ethernet
ISP Router: BGW320-505 (bridge mode)
Personal Router: Unifi Dream Machine Pro (UDMP)

Connected Audio Devices

BluSound Node 2
Topping DX3 Pro
Harmon Kardon integrated amp

Number of Tracks in Library

62,366 Tracks

Description of Issue

RoonARC will not connect for me. I have placed my ISP router in bridge mode, set up Port Forwarding rules on my personal router (UDMP), I have disabled the firewall settings on W10 machine hosting Roon core, all to no luck. Error message I’m receiving is below. Please help!

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“45.27.41.32”,“router_external_ip”:“192.168.1.64”},
“status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}
}

Hi Preston,

Sorry to hear about your issues getting ARC connected. Have you had a read of this thread which might help you get things sorted?

It looks like your ISP router is still doing NAT, even though you put it in bridge mode. Some ISPs (like one of mine) will not remove NAT from their routers, allegedly for security reasons, but really to conserve IPv4 address space.

Is it as easy as calling them to request NAT be removed? Or are there other workarounds?

Thanks for the article. In reading the directions, my settings do not show UPnP as an option to enable. I dug a little deeper and found a setting that said disabled and also said “UPnP can only be enabled on one Internet interface at a time”. IDK what else could be using the UPnP. I also do not have a setting for NAT in the UDMP either. Are my settings missing someting?


AFAIK, if your ISP router is doing NAT, there’s nothing you can do on UDM to preclude double NAT. The only way I could solve this with one of my ISPs (a coop fiber provider) was to file a ticket with them to create a manual port forward for ARC, with my UDM as destination, and then a separate manual port forward on the UDM with my Roon Core as destination.

But maybe your ISP allows NAT to be removed from their router. Worth asking…

Thanks for the reply. Looks like I’ll just have to give them a call in the morning.

Even if you are unable to put your modem into bridge mode (I was able to with my BGW210-700) then you should be able to forward ports on both devices (ISP modem and your router) to get around this.

Do,you need to use the AT&T modem? I have 1G from a different provider and just plug directly into my UDM Pro