Roon Arc with AT&T and Orbi router

Roon Core Machine

Dell XPS 15 9520 I9 32gb ram

Networking Gear & Setup Details

Netgear Orbi 960, Router connected to AT&T modem BGW320, Roon Core is connected to one of the Orbi satelites by ethernet cord.

  1. Who is your internet service provider? AT&T

  2. Please list the make and model of your modem and router? BGW320

  3. Do you have any additional network hardware, like additional routers or managed switches? Only 2 ORBI satellites

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices


Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I have a similar setup but with different AT&T modem and different model Orbi. For me thr trick was to setup up passthrough on the At&T modem. I then had to reboot the modem and the Orbi router and was able to get ARC to work fine. Do a google search to find the instructions for setting up ip passthrough on you particular model.

Not 100% sure that will do it for you as your error message mentions the ipv6 protocol which can be the source of all sorts of other problems that you will need to get networking experts to advise on. However my suggestion above is worth a try before going any further.

I have set up the passthrough and did the port forwarding on the router. I get it to work for a brief moment, but then it gives me the same error. Have been working on it for days.

If you’ve done the good old reboot on everything a couple of times as well then there is. not much else I can suggest.

Usually with the kind of error message you are getting ARC will not work at all so not sure what an intermittent problem is. Hopefully @support will be around after the weekend to look at your logs.

I have the same ATT gateway. The BGW320 is the only one that is not pretty much garbage. Having given the gateway that glowing praise, my first suggestion is to connect directly to the gateway to see if that works. ATT is notorious for having problems with a router-behind-router setup. I have the BGW320 and two ATT branded “extenders”. My setup works perfectly. I don’t know if ATT modded the BGW320, but they are notorious for crippling their supplied hardware. I had trouble with the previous ATT gateways and my guess is the “correct” setup is to setup the pass-through port on the BGW320 and leave the Orbi untouched. That is a guess. But connecting to the BGW320 should at minimum be a decent debug step. Good luck.

Thanks for the advice, I tried that a couple of days ago and it still did not work.

One other trick that may help, when you are logged into the att device and are assigning the downstream router when configuring passthrough in the configuration screen, pick the orbi from the dropdown list, do not try and add it manuallly. It should be present if connected properly.

If this is all done, can you confirm that your orbi sees the att public ip? If so, can you toggle it back to a DHCP assigned IP from the att box and then back?

Confirmed, Orbi sees the public IP

Only other thoughts, disable all firewalling in the att box, this does not happen automatically, Unlikely this solves it but give it a try. If this doesn’t work, go to a Netgear support site, their own or reddit and ask for helpn, as this is likely an orbi port forwarding issue.

Your core is connected to orbi, not att right?

Other thing you can try is taking the orbi out of the equation, and and setting this up using the bgw as a router. If you can get it to work, put the orbi in bridge mode.

I have the same att router, in passthrough mode running into a router/firewall that then an orbi in bridge mode hangs off of. Very similar setup, you definitely can get this to work.

Core is connected to the Orbi Satellite. All firewalling has been disabled.
I have tried connecting directly to the ATT modem but that did not work either.

You can remove orbi and assign your core as the downstream router in the att router and that would have to work. You must reboot the att device every time you change the passthrough device or it will not work.

Then work backwards from there, add back the orbi, then oort forward via orbi to core.

Connected directly to the modem. Below are my Passthrough settings from Passthrough.

Robooted the Modem, but still getting following error in Roon

Okay, restarted one more time and it does work now. Thanks for your help, I will begin working backwards to the router.

1 Like

Last Update, I got it to work through the Satellite. The key to everything is not to use refresh button in Roon to check if it works. You have to close down Roon completely and open it again. I believe this was my biggest problem all along.
Thanks to everyone and especially to Rob_Rodier for your help.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.