Roon ARC with Verizon Fios Quantum 1750 gateway (not G3100)

Roon Core Machine

Windows 10 Pro, 64-bit, Processor Intel(R) Core™ i5-4690T CPU @ 2.50GHz, 2501 Mhz, 4 Core(s), 4 Logical Processor(s), 16GB RAM, Dell Optiplex 9020 SFF

Roon bridge is a RPi 4 running RoPiEEE

Roon Version is 2.0

Networking Gear & Setup Details

Fios Quantum Gateway 1750 router, wired connection for Core

Roon Bridge has wired connection with FiOS Network Extender.

FiOs Network Extender connects to primary router (Quantum Gateway) directly through room-to-room coax to eliminate WiFi from entire signal path.

Connected Audio Devices

Roon bridge RPi4 is connected via USB to a Schiitt Modi Multibit DAC via USB

Number of Tracks in Library

12,024 tracks

Description of Issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I am guessing there might be a double NAT issue here, but I do not know enough to TS. Please let me know what I can try. I tried creating a port-forwarding rule, but same results. It would be great to get ARC working. Thanks!

I think the first part is resolved: the key was using canyouseeme to TS, and i finally figured out it had nothing to do with the router/gateway, but my McAfee firewall. once i got the port exception into the firewall rules, it began working and the error msg under Roon AR in Settings on the Core interface went away.

I am still having trouble pulling up any music from the Core on my Roon App on the phone - it keeps saying “Poor connection” and doesn’t play. However, the library view updated with recent adds etc


The second part is also resolved. I had to reset the Roon ARC app on my phone to redo the connection, and now everything works fine.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.