Roon ASIO not connecting to Schiit Audio DAC

Hi, I am hoping there is someone who knows how to fix this problem and can help me here. When trying to play music from Tidal or from local storage through ASIO from Roon to my Schiit Audio DAC, nothing happens. For a second it looks like the song is going to start but it doesn’t play at all. When playing music through Roon using WASAPI it works fine. When playing songs through Roon connected to HQPlayer to ASIO to my DAC it plays fine. Playing songs from Jriver through ASIO to my DAC it plays fine. Its only when I try to play songs through Roon ASIO directly to my DAC is when I run into problems. Anyway to fix this?

Here are pics of my settings. Everything is at default I believe.

I took the pics with my phone so if the quality is to bad to read, please let me know and I will find a way to upload images that are better quality.

Thanks to any who can help! :slight_smile:

EDIT: I forgot to add, I am running Windows 10 with the latest Roon software and latest Schiit USB Drivers.

Hi @Michael_Troia ---- Thank you for the report and my apologies for the issue here. The screen grabs are also very helpful, kudos! I would like to have you confirm some information for me as well as run a simple test to try and trigger a change in behavior. Please see below, thanks!

  1. Can you please confirm for me what ASIO driver version you are using?

  2. Can you please confirm the exact Schiit DAC model you are using?

  3. I’d like you to try the following test. Could you please disable the WASAPI zone, restart roon, and try playing back to the ASIO zone. Any change?


Thanks for the reply!

  1. I am not sure which ASIO driver version I am using. Is there a way to find out? I installed the USB driver from Schiit’s website and it gave me ASIO I believe. The name of the driver version is Schiit_USB_Gen3_W10_1_01, but IDK if that helps or not. Should I install a separate ASIO driver as well?

  2. The Schiit Dac I am using is the Yggdrasil.

  3. I tried disabling WASAPI zone and restarting Roon but it didn’t fix the problem unfortunately.

Hi @Michael_Troia ----- Thank you for the follow up and the feedback. I did some research into to the model DAC you are working with (yggdrasil FAQ) and noticed on the model’s FAQ page mentions that it can not do DSD playback. I noticed from your first screen grab that your “DSD Playback Strategy” is set to "native"and believe that this could be the culprit here. I would suggest trying the following:

  1. Setting “DSD Playback Strategy” to convert to PCM. Are you able to achieve playback?

  2. There are two boxes under “Bit-Perfect Format Support” (Use Max Hardware Buffer Size & Use Power-of-2 Hardware Buffer Size), I would suggest trying to check one box off at a time and see if there is any change in behavior. Next I would try having both boxes active at the same time and once again, see if there are any changes in results.


I tried all of your suggestions, both one at a time and also in combination with one another, an none of them fixed the problem. Roon still fails to play music through my DAC using ASIO. Is there anything else I can try?

Hi @Michael_Troia ---- I’d like to gather some logs from you and will be contacting you via PM momentarily. Thanks!


Any update on the Schiit ASIO driver and Roon?

1 Like

I believe we reproduced and have a fix coming for the next release. @Eric will confirm when it’s live.


Hi @dshore ----- Just wanted to follow up to confirm Mike’s post. We were able to reproduce the issue in house and a fix has been slated for our next release.


1 Like