Roon audio device skipping all tracks when connected to a particular USB port

Core Machine (Operating system/System info/Roon build number)

Windows 10 virtual machine running Roon Server (and nothing else). Server set up via ProxMox. Static IP. Firewall disabled.
Roon version 1.8 (build 756)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router: Ubiquiti AmpliFi HD
Roon Server: Windows 10 virtual machine set on a static IP. Windows firewall disabled. No other additional programs installed. Connected to the network via ethernet.
Media files: Located on a Synology NAS with a static IP.
Roon devices: Schiit Modius connected via USB to a desktop computer with DHCP enabled. MiniDSP SHD connected to the network via ethernet with a static IP.
ALL devices are on the same physical network and the same subnet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Audio Device 1: MiniDSP SHD. connected via ethernet.
Audio Device 2: Schiit Modius. Connected to desktop via USB.

Description Of Issue

Good afternoon!

Recently I started having an issue with one of my audio devices and Roon. When I go to play a track, it appears to attempt to play the track, fails, skips to the next available track, fails, ad infinitum. This only recently started happening on my desktop computer with my Schiit Modius. Both my MiniDSP SHD and my cell phone are able to play both Tidal and library files through Roon just fine. the Modius also serves as my primary audio device for this computer, and is working just fine. Roon clearly sees the Modius connected to my computer. When I changed USB ports, it re-connected to Roon and now it seems to work…

Could it be something to do with Roon expecting the device to appear on a particular COM port? I have disconnected and re-connected a few usb devices recently. I’m unusure if the Modius was disconnected as part of that. Should I note which COM port it is on and be sure to make sure it always on that particular one?

What I tried:
-Restarting the desktop with the Schiit Modius
-Connecting and re-connecting the Schiit Modius
-Restarting the VM (Roon Core)
-Restarting the VM Server
-Connecting the Schiit Modius to a different USB port (FIXED THE ISSUE)

Thank you for your time and assistance!

Hi @Dewey_Greer

The USB port that the device is connected to shouldn’t matter to Roon. If there is an issue with the connection (i.e. a hardware problem with that particular port) that prevents Roon from properly sending audio to the device, that could certainly result in this type of issue, though.

Thanks for the reply Dylan!

So far I haven’t had an issue with any other software on this computer using the Schiit Modius. It is my only audio device that I use on this computer, and I use it every day. And just today it started having this issue again. I notice that this time, when I connect it to a different USB port, the audio zone disappears from the list of available zones on Roon. I have to go to Settings->Audio and enable the device and give it a new nickname. And it still doesn’t work. I tried putting it back to the original USB port, and it pops up right away with the old device name. Are you sure it isn’t linked to a particular USB[x] port? And how should I go about troubleshooting this issue?

Thank you!

Hi @dylan ! Just wanted to bump the thread. I’m still experiencing the same issue. Hopefully you will have some insight?


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.