Roon & Audio Files Loading Slowly [Solved - IGMP Settings]


(Dan Clark) #1

Same situation here, with images sometimes not loading, and constant “An audio file is loading slowly…” errors.

Roonserver 1.5
Roon Core 1.5
iMac 27", os 10.14.2
Synology 1600 router, ROCK and Mac on LAN not wifi

ROCK
NUC i7, 8GB, 256GB SSD (fast one), 6 TB RAID

Works for a few minutes, then get worse and worse whether Tidal or library. Restarting everything restores function, briefly, then it quickly degrades.


Roon is very, very slow
(Daniel Beyer) #2

The following info might help, How many tracks are in the library? What Raid Enclosure are you using? What is the audio playback chain?


(Dan Clark) #3

6TB Sony Raid via USB 3

Playback is Rock->iMac->Schiit Yggy via USB, but also the problem occurred using the Mac->ROCK->Ropieee coax to Yggy

library is 1100 artists, 24,000 tracks

Also running Synology 1600ac router with current firmware, but the ROCK, iMac and Roopiee are all LAN.


(Noris) #5

Hello @Dan_Clark,

Thanks for contacting us regarding this issue. I have split your post to provide more individualized attention for your case here. We have seen users have a better experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?

Thanks,
Noris


(Dan Clark) #6

No, still running into some issues. As usual making a change works great for 5-30 minutes or so then something degrades. This time local content played but it stalled loading a Tidal album.

Restarting the Roon client the album loaded right up.

Tried loading “favorites” in Tidal and Error Loading Page, Please Check Your Network Connection."


(Noris) #7

Thanks for letting me know that info @Dan_Clark. Here’s what I’m going to do: I will enable diagnostics mode for your account and what this action will do is next time your Core is active a set of logs will automatically be generated and uploaded to our servers for analysis.

To be sure that we have the proper information to analyze, I kindly ask you to reproduce this issue once more and then note the exact local time in your country (ex. 10:42PM) that you notice this behavior again also the exact time of when restarting fixed the issue. After receiving these timestamps and the logs I will ask QA to take a look for any strange behavior “under-the-hood”.

Thanks,
Nris


(Dan Clark) #8

It didn’t take long. First track I tried to do started then halted at 9:33AM Pacific. Restarted RCOK 9:35AM and track plays.


(Dan Clark) #9

Happened again, 10:46AM. Was listening to an album, which was playing back smoothly, switched to a new album and got the “loading slowly” message again. Restarting the client took a while to connect to the server, after roughly a minute the server connected then the album loaded.

Another server restart at 1:50PM today, files loaded slowly.


(Noris) #10

Hello @Dan_Clark,

Thanks for letting me know those timestamps. I took a look around those times in your Core’s diagnostics and I did indeed notice those issues. They seem to be networking related to me since your DACs abruptly disconnect.

Do you know how to access the Web Administration page for your Router? In the past we have seen these options help with other routers, your report is the first I’ve seen with a Synology router but I would give it a try regardless:

  • Enabling IGMP Proxying
  • Enabling IGMP Snooping
  • Disabling Energy Efficient Ethernet
  • Making sure that Multicast Router is enabled

Please let me know if any of those options help.

Thanks,
Noris


(Dan Clark) #11

IGMP appears to have resolved it. I’ll let the system run a couple of days and post if we do/do not have further issues.

Thanks for the prompt support!


(Dan Clark) #12

Problem appears to be resolved. If we have further issues Ill post. The IGMP settings did the trick, there is no energy efficiency or multicast setting I could find in the Synology router, so those were not tried/needed.


(Noris) #13

Glad to hear that @Dan_Clark! I have added that Synology Router to our Networking Best Practices page in case other users experience the same issue :slight_smile: .

I wish you a pleasant listening experience and thanks again for contacting support! :headphones:

– Noris