Roon audio loading slowly. May indicate performance problem

Roon Core Machine

Core: Nucleus+
Remotes: Windows 10; Dell XPS 8700 desktop computer, iPhone

Networking Gear & Setup Details

Home network using ethernet cables & switches
Vortexbox NAS

Connected Audio Devices

NAD M50.2
Devialet Expert Pro 220

Library Size

Description of Issue

My local electricity company shut off power to my home in order to install a new meter. After that Roon was not working properly so I did the following:

  1. Reinstalled the Roon operating system
  2. Restarted the Roon server software
  3. Reset the Roon database & settings
  4. Reinstalled a Roon backup session (containing play lists etc.)
  5. Reinstalled the Roon remote app on my iPhone

At first no music would come through my speakers - just unintelligible noises. So I repeated items 1 to 5 above. Now music starts playing but I am getting the messages that an audio file is loading slowly and this may indicate a performance problem and then Roon skips to the next song where I get the same message. I have gone to the Roon community postings but so far have not found a solution to this problem.

Can anyone help?

Typically a network issue. What router do you have?

@ged_hickman1 is right, this is most probably a network issue. You mentioned you’d rebooted your server, but I’d also suggest rebooting every device in the chain (NAS, endpoints, amps, router, switches etc). This will help to rule out any glitches that may have been introduced by your recent power outage.

My router is an ASUS GT-AC5300

Hi @Greg_Johnson, since the power outage have you tried giving your router another reboot?

Do you experience the same issue if you play to System Output of a remote device?

What kind of music are you trying to play? Local content or Tidal/Qobuz? Is there any difference between source?

I rebooted the router and also unplugged and re-plugged my Devialet Expert Pro 220 amp, NAD M50.2 ripper/server/NAS, ethernet switches, Vortexbox NAS & Roon Nucleus+, power conditioner. I rebooted my Dell XPS 8700 desktop computer.

I also restarted my Roon software and reset the Roon database & settings again.

Roon is not finding my Devialet Expert Pro 220 amplifier as an audio device so I am unable to play anything. Also I do not use Tidal/Qubuz. I only use local content (i.e. CD’s) that I have ripped to my servers.

Thanks for the details, @Greg_Johnson.

If you select System Output from Settings > Audio does that play okay?

Can you share a screenshot of Settings > Audio?

Dylan; If I select System Output from settings it indicates that it is playing but no music is coming our of my speakers.

As you can see my Devialet Expert Pro 220 is not identified as an audio device even though it is Roon ready.

Thanks, @Greg_Johnson. Okay, let’s start with taking a look at the playback issues.

Can you do this once more, make a note of the track that you try to play, and then use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? I’ll take a look at what’s happening in the logs.

Dylan; I tried to use Windows to open file Explorer and navigate to \NUCLEUS+\Data

Attached is a screen shot of what happens.


As indicated in my previous communications, my local power company shut off my electricity, in order to install a new electrical meter and that caused a string of problems. Trying to solve the message that “Roon is loading slowly and this may indicate a performance problem” led to other problems such as Roon not recognizing my amplifier as an audio device.

After no success in getting Roon or my ASUS GT-AC5300 router to recognize my Devialet Expert Pro 220 amplifier as an audio device I started looking at the ethernet cable connections.

In my music system an ethernet cable goes from a Linksys switch to an Ethergen switch and then another ethernet cable goes from the Ethergen switch to my Devialet Expert Pro 200 amplifier. An Afterdark clock is hooked up to the Ethergen switch and both are powered by an Afterdark linear power supply.

I removed the Ethergen switch and ran a cable directly from my Devialet Expert Pro 220 amplifier to the Linksys switch and then rebooted Roon. Lo and behold my Devialet Expert Pro 220 amplifier was now recognized by both Roon & my router (see attached screen shot)

I then reinserted & connected my Ethergen switch and Afterdark clock and my Devialet Expert Pro 220 was still fortunately being recognized by Roon and my router.

I had another problem with the Roon remote app on my iphone. I shuffled the music tracks but when I tried to play them, no music was coming out of my speakers but the app indicated that a song was playing. The trouble was it also indicated that every 4 seconds it was changing to the next song. So I deleted the app from my iphone and reinstalled it. That solved the problem and I was able to play music through my speakers using the app.

Intermittently in the past I have gotten the message “Roon audio is loading slowly; this may indicate a performance problem” Do you have any advice about what is causing this message to appear and how to solve it?

I would still like to be able to send you a copy of my Roon logs or database, but as I indicated in my previous communication with you, for some reason the Roon Labs Help Center instructions for doing so for Nucleus Core do not work. do you have any suggestions as to how to solve this problem?

I am 71 years old and I must say that at my age I find the digital world very flaky & challenging especially with regard to music systems like my mine.

Take for example the problem that I have had for years, that the Roon community, different computer experts that I have hired, ASUS (for two diffferent routers used) and NAD have not been able to solve, of my not being able to assign a static or reserved IP address for my NAD M50.2 server/ripper/player. Then there is my Roon software that often goes “bezerko” when the power fails or is shut off or software updates are made or I try to introduce new components to my system.

I recognize that my music set up is complicated and that there are others in the Roon community that have different music systems that may be just as or more complicated than mine. I am hoping that Roon is tracking the problems that all of us are having and hopefully finding certain “common problem themes” that will lead to solutions.


Screenshot (91)|690x388


Hi @Greg_Johnson, thanks for the detailed followup!

You’ll want to enter \\NUCLEUSPLUS\Data (with the + spelled out as PLUS). Can you give that a try?