Roon automatically changing the default output device - corrupted?

Core Machine (Operating system/System info/Roon build number)

Mac Mini (2018)
3.2 Ghz 6-Core Intel i7
MacOS Catalina 10.15.7
Roon build 1.7 build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi- All connections strong

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon Remote
MacBook Pro (2018)
2.7Ghz Quad-Core Intel i7
MacOS Catalina 10.15.7
Roon build 1.7 build 667
Kanto TUK - external dac/powered speaker connected via USB (using Roon Exclusive Mode)

Description Of Issue

I am noticing seemingly new behavior by Roon when exclusive mode ‘activates’ on one of my playback zones.

Specifically this zone is for an external DAC/powered speaker connected by USB to my Roon Remote Device (Mac Book Pro). This zone is called ’TUK by Kanto’ and is set to use Exclusive Mode.

’TUK’ is configured as the default sound output device in both the Preferences/Sound Pane and in the Audio MIDI configuration. See the following screenshot #1.

However, as soon as Roon starts playing in exclusive mode to the ‘TUK’ zone, the system automatically changes the output device ‘to MacBook Pro Speakers’ in both the Preferences/Sound Pane and Audio MIDI device configuration page. See the following screenshot #2.

Even though the default devices show ‘MacBook Pro Speakers’, the sound plays through the external TUK speakers. It’s not clear to me that this is truly in exclusive mode or the proper behavior.

As soon as Roon stops playing to the ‘TUK’ zone, the default device automatically changes back to ‘Kanto by TUK’ in both sound output device in both the Preferences/Sound Pane and in the Audio MIDI configuration. That is, the default configurations automatically change back to Screenshot #1.

This seems to be new behavior. I do not remember the default sound output device automatically changing when playing to ’TUK’ in exclusive mode previously.

I have tried re-installing the OS, resetting SMC and PRAM, all without success.

Could Roon have a corrupted preference or other file? Is there some way to reset this so that Roon keeps the default sound output device as ‘TUK’ even when playing in exclusive mode??

Thanks.

HI - just following up on the below. Can you please advise.
Thanks.

Hello @Jordan,

Thanks for reaching out! I’ve requested some feedback from the technical team regarding your case here, thanks for your patience while we look into your report!

Hello @Jordan,

I checked in with the technical team on this and this is expected behavior. System Output is automatically selected because the exclusive mode device is unavailable to the operating system. Exclusive mode means that only one application can control the audio driver at a time, and if Roon is using it, then the MacOS system will be unable to use it.