Roon Backup failed

Roon Core Machine

Mac mini M1 2020

Networking Gear & Setup Details

Jazztel-Livebox-Ethernet connection

Connected Audio Devices

Denafrips Ares II DAC - USB connection

Number of Tracks in Library

56.000 tracks

Description of Issue

Every time the system tries to do a backup, scheduled or forced manual, it fails. The message is the one below. I think it happens since the last Roon update.

Can you do a new one? from add
Screenshot 2023-01-03 at 00.34.09

There could be several reasons your backup is failing:

  1. Roon should be doing nothing, i.e. in complete rest, when your backup needs to start (so no music playing, …)
  2. Do you have enough available space on your NAS. Apparently you want to keep 99 backups, that takes quite some space.
    Why ? - Every other update Roon’s database structure needs updating , i.e. is changing) , so I am convinced that using a backup of 2 more than 2 months old will never restore to a ‘good’ state.
  3. It can be your existing backup is corrupted , and can be ‘updated’.
    So as Traian_Boldea suggests, try to add a new one at another location (or force a new backup)

Yes, that is a great point. No use for 99. Since I was on a big HDD I was going maximum. But I was wrong. Thanks

As far as I understand the issue at hand, your database is toast and that is also the reason for the failing backups – you have to create a new error free database first:

Hello again. Thanks for your suggestions. I have tried the different options, I have even deleted the two backup copies that I had stored and it does not work. The last copy made by Roon was last December 10th. I have also tried it in another location and the same error. What I can do? Thanks in advance for your help.

Is your backup location visible to Roon? I recently moved my core to a small intel NUC and used ROCK as my OS and I had some failed to backup messages and when I looked into it. Roon couldn’t find my backup folder. Once I remounted the folder and confirmed the backup path was correct all is good again. Also as stated Roon must be at rest in order to back up.

Do you have access to another PC (Mac) where you can do a fresh install of Roon and try a restore of your latest succesfull backup?

It’s not possible to backup a corrupted database, Roon simply doesn’t allow it (anymore). What’s the point of a corrupted backup anyway?

I don’t have another Mac to try installing the core and see if it works correctly. I just have another Windows PC. Based on your suggestions, in case the source of the problem was a corrupted copy, I have deleted them all. I’ve thought about completely uninstalling Roon and going back to a fresh install. I’ll write down the settings to retrieve later.

Finally I have not uninstalled Roon. I am reluctant to believe that Roon is not capable of giving me an answer to the problem of not being able to perform backups. Why I am going to lose all my settings now without being sure that the problem will be solved later? I ask the Roon team to give me a solution so that I can continue having my backup copies stored, as I did until December 10. I haven’t changed anything to make this happen. I look forward to your comments. Thanks and kind regards.

This is how my Roon continues, without backup copies. Yesterday, it



tried again with the programmed copies and it failed again. Please, can anyone guide me in solving this incident? Thanks and kind regards.

HI @Manuel_Quijano_Ramir,

I’m trying to use Google to translate the error but the gist I see is that the backup failed.

What happens if you change your backup location under Roon>Settings>Backups>? Under scheduled backups, click view and then the three dots to re-map it to another location and/or remove the backup that is scheduled and set it again.

Thanks,
Wes

I have unscheduled all backups, closed Roon and rebooted the mac. Then I tried to make a new backup in another location. The result is the same and the message is also the same as before. Do you think if I uninstall Roon completely and do a new clean install it will work fine? I can’t think of any other solution and I don’t understand what the problem could be. Thanks for your help and I look forward to your comments.

Finally, removing Roon completely from my mac and doing a clean install again resolved the issue and now the system did a first manual backup. I have reprogrammed the ones that will be carried out automatically. Thank you for your help and I hope the problem does not recur. It’s tedious having to re-enter all the settings. Kind regards.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.