Roon Backup Failing Every Time

Core Machine (Operating system/System info/Roon build number)

Nucleus+ version 1.8 (Build 763)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Backing up to Synology NAS, All connections Ethernet, a Netgear switch and Orbi router between the Nucleus and the NAS.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bryston DAC, USB

Description Of Issue

The last successful backup was January 30th. Since then I have tried a couple of manual backups and have weekly automatic backups set up. Every time I’ve noticed, I have an alert that the backup failed.

I just tried a manual one:
!) Before I started I checked from my desktop computer that the NAS directory was accessible
2) Then within Roon, I selected the path for the manual backup. The path is on the NAS and all looks fine.
3) When I selected Start, Roon was unavailable for about 1 minute, then about a minute later reported that the backup failed.
4) I went back to my desktop and the NAS folders are still accessible from there.

Both the music files and the backup folder are on the NAS, just in separate parts of the shared folder structure. I don’t have a problem playing from the NAS.

The music database is about 2.3 TB in size (Roon reports 4564 artists, 11858 albums, 103540 tracks).

The NAS has 6.4TB free.


Hi, couple of quick questions - when is your auto backup scheduled? Are all music streams in Roon stopped/paused at the time of the backup? Roon can’t backup while music is being played. I set mine to backup during the night when music shouldn’t normally be playing.

Thanks for the response. The auto backup is scheduled for 1am. We’re asleep by then and I always pause the music before I go to bed. When I do the manual backup, the music is definitely stopped then too.

I just tried a manual backup again and watched progress. I got a “processing…” message for about 20 seconds, then “transferring…”. It progressed from 1% to 10% then stopped and gave me the error “Backup directory not available”. So I went back into Backup and I can select that directory without a problem. So something is going awry partway into the backup.

Hey @Steve_Davies1,

Thanks so much for reporting this issue - we’re sorry about the trouble. One of our Roon technicians will reach back to you on this thread.

In the meantime, thanks for trying everything that you have and thanks @Graeme_Finlayson for stepping in to help.

I suspect you all are swamped with 1.8 cleanup, but I’d really like to backup my room database! It always fails.

1 Like

Well this is disappointing customer service. I guess I’ll just let this die. Do other people attach a USB drive to their Nucleus for backup? Maybe I need to do that.

Hi Steve, another thought I had - is SMB service enabled under Control Panel - File Services? I also use a Synology NAS, however my Roon Core runs on the NAS, so my setup is slightly different.

Thanks for the help Graeme! I checked that and SMB is enabled. I don’t know what that does, so should I uncheck it?

While waiting, I’ve run a complete diagnostic on the NAS (file consistency check & SMART disk diagnostics). I got a couple of warnings along the way but everything reports as normal. So I just reran the backup and it still failed with “Backup directory not available”.

During my next wait I guess I’ll try connecting an external drive to the Nucleus and see if backup works to that.


Hi Steve, SMB should be enabled. It allows Windows, Mac and Linux systems with SMB/CIFS support to access data on the NAS. I believe Roon uses this protocol for the Music Library as well.

Yes, SMB is enabled.

Steve, it sounds like it’s somehow permission related - was your last backup around the time of the 1.8 update? I’m trying to figure out what might have changed. Have you tried removing the backup path from Roon and setting it up again? Is your Roon backup folder location in it’s own distinct, separate folder?

As I said earlier, this is new territory for me as Roon lives on my NAS, so it automatically has root access to mount shares/folders (DSM 6). DSM 7 may queer the pitch a little when it lands, from what I’m reading.

Have you added correct credentials for that network share?

@anon1796887 thanks for weighing in. I’m not sure where that control panel is – in Roon or on the Synology NAS?

I should clarify:

  • This backup DID work until the beginning of the year. Since then it’s started (sometimes even getting 50% into the backup) before aborting.
  • From the Nucleus, I can select the folder where I want to back up
  • The Nucleus can play music from the NAS (albeit from a different folder)

Happy to look at that control panel, I just don’t know where it is.

Sorry, I should read more carefully responses. You can ignore my previous post, as you have had working network share with access rights before and everything else has stayed the same, the problem is not at where I was looking it.

No worries, I appreciate the offer of help! I’m going to see if I can find a USB drive around here somewhere and use that.

Hey Steve,

you could check the log files. See here (search for the Nucleus chapter):

In the log file watch out for the keyword “backup”. Maybe you can see something helpful.

Thanks @oliver_stettner, good thought. I’ll take a look this weekend – real life is overshadowing music life right now.

Ok, I’m finished with this – I have a solution that is sufficient but not what I’d prefer.

  • I reviewed the Roon logs and don’t see anything that I can figure out. The backup seems to start as it should but just dies a little while later when it can’t find the folder (even though it had seen it through multiple file copies before).
  • To eliminate the possibility that there was a time-of-day conflict, I moved the time of the automatic backup, it didn’t appear to have an effect
  • I ran through a complete, multi-day diagnostic of the NAS, which turned up nothing.
  • I turned on notifications to let me know if anything untoward happens on the NAS. I get ONE message each day: That there is a file problem when the Roon Backup runs. The timing of that email changes when I change the time of the Roon backup. I cleared a bunch of data off the NAS to see if somehow Roon was repeatedly writing to a marginal spot, that had no effect. I don’t get an error message at any other time – the one arising from Roon’s backup is the only one I get.
  • I cleared off a USB drive, attached that directly to the Nucleus, and directed Roon to back up to that USB drive. That’s been running fine for a couple of days. I don’t know if I can integrate that into my off-site backup process, but since I have all of my music backed up to the cloud, I guess I can live with that.

So I’m done worrying about this. I still believe there is a problem with how Roon is accessing the NAS server for backup, but without Tech Support from Roon, I can’t solve that problem – it’s beyond my technical chops.

@beka I’m frustrated that no one else from support ever responded on this, even after a month. I’m going to let the thread die rather than continuing to spend time on it.

Hey @Steve_Davies1,

I’ve been reading the entire thread and I can only thank you for your efforts, engagement on our community and kindness.

I can see how frustration levels can rise in this context…I’m so sorry that it’s been so long since you’ve reported this and that none of us has yet had a chance to reply. This is not how we wanted things to happen.

While I am glad you can use Roon, it’d be great to also be able to backup Roon. This is still in our technical team’s queue and, if you don’t mind, we’d love to have it here and get a chance to take a closer look at what might be happening :pray: