Roon Backup Invalid path

Roon Core Machine

iMac with M1 chip; 16 GB; Ventura 13.2.1; 949 GB storage available

Networking Gear & Setup Details

xfinity internet modem with 2 GB speed verified; using eero wifi routers; xfinity modem set to passthrough

Connected Audio Devices

  1. Naim ND5XS 2 streamer
  2. airplay to Control4
  3. Sonos components

Number of Tracks in Library

approximately 5000 tracks in Apple music and also using Tidal

Description of Issue

When trying to specify a backup location, constantly get “invalid path” message. This occurs whether I specify a location on the iMac or a location on an external hard drive

Are these the steps you tried and if so, where do you get the error

  1. Open Settings / Backup
  2. Choose Backup Now
  3. It will ask you to select location and display the drives on the core machine. Click New Folder on the bottom and enter Backup_Test. At this point, at the top the selected folder section should read the entire path including the new folder you’ve entered.
  4. Click “Select This Folder” blue button on bottom.
  5. It should bring you back to the Manual Backup, the selected path should be shown. Click Start.
  6. The backup should start. When done, the Backup Status area on the Backup page should indicate the folder location and backup date/time

Yes I have tried those steps several times and specified different location including external drives but keep gettin “invalid path”

Same problem here. The backup feature of Roon, I will have to say, is inscrutable with the command line trial and error process. I was able to make a backup, now I can’t access it again and the location that seemed to work no longer works. I’m really looking for some help here.

Same problem here, all I get is invalid path. Backup directory not available.

@Paul_Montgomery & @Matt_Cross - please open Support requests, giving details of your setup in the post template, and screenshots of Roon’s Backup locations (e.g. Settings > Backup > View or screens showing the error message) would be useful. The more information you can provide, the better the Support team will be able to diagnose your issues.

I’m still waiting for a response from Roon support. So far, they merely copied and pasted the instructions for creating a backup. This issue appears to be a longstanding problem based upon old posts I have come across.

Not so. Please post a screenshot that shows the “invalid path” error message - that may tell us more about what is happening in your situation. Thanks.

Okay, I submitted the support request.

Thanks for the help.

Geoff, correction to my support request; My Core is a Roon Nucleus with a 2TB SSD drive. My MacBook Pro is a client. I am trying to set up backups of the Roon database on my Nucleus to my MacBook Pro.

My Mac is NOT a Core.



OK - saw that, and I’ve replied to your post there… Thanks.

Hi Geoff, thanks but restarting my Nuc rock and disconnecting and reconnecting my hard disk seems to have solved the problem. If only everything was as simple :+1:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.