Roon Backup only on network shares?

Roon Core Machine

Innous Zen mk3

Networking Gear & Setup Details

Connected Audio Devices

External HD via USB (Toshiba Canvio 2TB)

Number of Tracks in Library


Description of Issue

While I was using Roon 1.7 and 1.8 I could store my backup on a external, directly attached to the Roon Core USB drive.

Today I wanted to start a manual backup, but I couldn’t choose my HD, only network shares?!
So I got stuck in the process… using Roon 2.0 (build 1211).
How can I choose my USB attached HD to store the backup that worked with earlier Roon versions?

Edit: Even when I try to work around the problem with adding a network share to a folder in my desktop computer (Windows 10) in another room, I always got „Invalid network path“ as error message.

I have a USB attached and can choose it as the backup location and back up to it just fine. Is your USB possibly formatted as NTFS? If so, it may have been previously unsafely removed (unplugged either from a PC without going through the safe remove procedure or from a running Core), which would leave an “unsafely removed” flag on the file system. Current RoonOS versions have become picky about this for safety reasons (unsafely removed NTFS file systems are prone to later corruption) and it may refuse to access it until this is fixed.

If the USB disk is NTFS and there is nothing on it, you can reformat it with a more suitable file system (exFAT most simply). It’s also possible to clean it up with a Windows PC by attaching it, opening a command prompt as Administrator, and running the CHKDSK /f command for the disk

If it’s not NTFS the issue will be something else

Hello, the drive (Toshiba Canvio 2TB) is NTFS formatted. The only use is to make music server backups. I attached it to my office computer (first time now) and there were no errors found when scanning the drive.
Like I said, it worked fine under Roon 1.7 and 1.8 when I did the last backup.

Did you do the CHKDSK /f ? And did you try if it works after that?

Yes, and like I said, current Roon versions have become pickier about this. This started with Roon OS version 254 in November 2022 (after the Roon app was already version 2.0)

One part of the “vastly improved” here meant that it has started to strictly refuse NTFS files systems with error flags:

1 Like

This reminds me of MS-DOS in the early 90ties :slight_smile:

When I plugged the Drive in, I right clicked on the mouse, and on „properties“, I clicked on tools > check disk. (There were no further options available).
The scan report said that there were no errors found.

Why I emphasized on „it worked beforehand“, was to point at Roonlabs and why did they try to fix something that wasn‘t broken, but it’s broken now… (that is diplomaticly called ‚pickier‘ now).

The HD is not recognized and network shares won’t work either, as there is no browse option.

I suppose that the checking for errors in the GUI should also do the right thing, but I am not sure. You could also try what I hinted at:

  1. Insert USB disk in Windows. Note the drive letter it receives, for example “e:”

  2. Search for “command” in the Windows Start menu

  3. When the command app is shown in the Start menu, rightclick it and click Run As Administrator

  4. Enter chkdsk /f E: (using the correct drive letter) into the command window and press Enter

This whole thing may not be the cause of your issue, but it’s a known issue that came up a lot on the forum after the RoonOS update to build 254, so surely it is best to rule out first.

Because it was broken and they did not have a choice about it.

  • Accessing / writing to NTFS file systems that were uncleanly removed or have other error flags can lead to fatal corruption later. And Roon said that they did see such cases.
  • Roon OS uses the Linux operating system kernel and the NTFS driver used by older Linux versions did not properly check for such issues in all cases. And it had other issues with NTFS as well. Keep in mind that NTFS is Microsoft’s proprietary file system and not completely documented in the public. The Linux developers had to reverse engineer it, which is very, very difficult to do. (Not even Microsoft themselves have a 100% error free NTFS driver. File systems are complicated)
  • In spring 2022, the Linux kernel received a new, completely rewritten, and much better NTFS driver. One part of this is being more strict about only accepting NTFS disks without error flags. Roon OS got that when they updated to the new Linux kernel. (I explained this in much detail in an earlier post)

Also note that the Roon OS documentation advises against using NTFS. The fact is simply that, being incompletely documented and proprietary, it is extremely difficult to implement without errors if you are not Microsoft. This is about music storage disks, but the same applies to backups:

1 Like

Thanks for all your valuable input.
I think I try next the following: copying my old backups to my desktop computer, then formatting the Toshiba HD as exFAT, copying back the back ups and then try to add a new (incremental) back up with Roon.

1 Like

This may well be the easiest approach :+1: I hope that it will solve the problem (and in any case is probably safer for the future) but if not, we’ll have to look at other causes.

Unless someone else chimes in and has a better idea!

1 Like

I now already started the process of copying the back up. Even though both units are USB 3 standard (heck, even 3.2) and the theoretical maximum speed is 5 Gb/s, the reported copying speed in windows is on average 100 Mb/s, which is a fracture of what should be achieved and will take another estimated 13 hours to finish…. :roll_eyes:



This couldn’t be more true, because meanwhile it displays 45 minutes to go….


Update: I formatted the HD as exFAT and put the older backups back. That took a while.
So instead of NTFS I connected an exFAT HD to my Roon core, but the backup options remain the meager same:

Conclusion: all your and my efforts did NOT come to fruiton.

Have you tried Use add network share to add the drive.

:frowning: OK weird. If a USB drive is connected locally and works, for sure it should show up there.

Your Roon Core is an Innuos Zen Mini. Perhaps they do things differently there? If it can share the drive out over the network, then as @Rugby suggests, add it as a network share…

1 Like

Yes it didn‘t work out. Got an error message „unexpected error“.
Dear Roon Labs please make a bug fix.

It‘s a Zen mk3, not mini.

Please post a screenshot of Roon’s “Add Network Share” screen showing the error and the information that you entered into the screen. Thanks.

Here it is (share = my office computer):

Edit: Screenshot removed for privacy reasons

It did not work either when I removed user and password…

It seems unlikely that the username for the network share is actually your email address unless it was specifically configured that way. Plus you probably don’t want to reveal your email address on a public forum

Find out what username/password the share really expects. You can probably find that in the settings for the share on the machine that is sharing